[DRBD-user] Remove a DRBD resource

Robert Altnoeder robert.altnoeder at linbit.com
Wed Mar 27 10:08:44 CET 2019

On 3/26/19 6:59 PM, Marcio Demetrio Bacci wrote:
> Hi,
> I have two resources in the node, but I need to remove the
> storage-rede resource.
> I run the following commands:
> 1. drbdadm down storage-rede
> 2. drbdadm disconnect storage-rede
> 3. drbdadm detach storage-rede
> 4. drbdadm invalidate storage-rede
> None of the above commands solved my problem.

drbdadm down should have removed it. None of the other commands remove a
DRBD resource from the kernel.

> root at server01:~# drbd-overview 
>   0:hd146         Connected    Primary/Secondary UpToDate/UpToDate C 
>     r-----   /vms ext4   125G 78G 47G 63% 
>   1:storage-rede  Unconfigured . 
> How could I remove the DRBD resource storage-rede  (Unconfigured) ?

Try the drbdsetup down command.

Also, since drbd-overview does not complain about being deprecated,
which newer versions have for quite a long time now, I wonder which
version of DRBD and drbd-utils you are running.


More information about the drbd-user mailing list