[DRBD-user] drbdadm down fails, but I already unmounted

Stefan Seifert nine at detonation.org
Wed Nov 19 09:56:20 CET 2008

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On Wednesday 19 November 2008 00:52:06 Allen Chen wrote:
> I tried to unmount one of my filesystems and detach, but
> got an error, device is busy. I tried to force the unmount by killing
> the process but that didn't work, so I used the command "umount -l /..."
> Then when I tried to run "drbdadm down r1" I get this error:
> /dev/drbd1: State change failed: (-12) Device is held open by someone
> Command 'drbdsetup /dev/drbd1 down' terminated with exit code 11
> Even though I already unmounted it. I don't really know whats causing
> it, and where to start looking to fix it...

No, you didn't unmount it. You just told the kernel, that whenever the file 
system is not in use anymore, it can unmount it. But since it an immediate 
umount doesn't work, there's no reason to believe that it would go away by 

You just have to find out, which process is still using your file system and 
get rid of it. The fuser command should be your friend.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20081119/e69b53a0/attachment.pgp>

More information about the drbd-user mailing list