[DRBD-user] drbdadm down fails, but I already unmounted

Allen Chen allen.chen at csagroupllc.com
Wed Nov 19 00:52:06 CET 2008

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.


I am still pretty new to DRBD and am having some trouble. I was able to
successfully load DRBD and run it on my servers a week ago, and the
tests ran fine. I tried to unmount one of my filesystems and detach, but
got an error, device is busy. I tried to force the unmount by killing
the process but that didn't work, so I used the command "umount -l /..."
Then when I tried to run "drbdadm down r1" I get this error:

/dev/drbd1: State change failed: (-12) Device is held open by someone
Command 'drbdsetup /dev/drbd1 down' terminated with exit code 11

Even though I already unmounted it. I don't really know whats causing
it, and where to start looking to fix it...

Then weird thing is i also have drbd running on another resource, r0,
which works perfectly fine, but r1 seems to give me trouble attaching
and detaching. Any help would be great.


More information about the drbd-user mailing list