[DRBD-user] Packages for Proxmox VE 6

denis at made.net denis at made.net
Sun Jul 14 23:33:06 CEST 2019

Il 14/07/19 19:35, Gianni Milo ha scritto:
>     I successfully create a VM with disk managed by linstor-proxmox and I
>     see the vm-100-disk-1 syncing... in sync on two nodes!
> What about the 3rd node? Is that not syncing or you have configured it 
> as a Diskless node?
> Have you set the redundancy number to 3 in storage.cfg ?

I use to set redundancy 2 on my cluster,  so a third node is not used 
for a single volume

>     But I get an error when I start the VM
>     (it starts withoud drbd disk)
> Have you tried starting it on one of Diskfull nodes?

Do you mean diskless node?

Interesting, just tried but same results, see logs later

>     before pasting logs, another strange thing is that if I broswe the
>     content of drbd storage, from proxmox, I can't see the VM disk but
>     I get
>     the status and the %usage
> I think this is broken on PVE5 as well. I cannot browse the content of 
> the drbd storage in the webgui but I can see the total amount and the 
> space used in the summary tab. This used to work in the past but I'm 
> unsure at which stage it got broken.

I run a similar 3-nodes production cluster with PVE 5.4-3 and linstor 
0.9.5-1 and 0.9.2-1 witch shows the storage content

> Here. It complains that the drbd volume is not in a writeable state 
> for some reason (read only?).Confirm its status with drbdtop and make 
> the necessary actions to switch it in the correct (writeable) state 
> (Primary?).

drbdtop is normal:

│Resource: vm-100-disk-1: (Overall danger score: 0)
│ Local Disc(Secondary):
│  volume 0 (/dev/drbd1001): UpToDate(normal disk state)
│ Connection to p6t2(Secondary): Connected(connected to p6t2)
│  volume 0:
│   UpToDate(normal disk state)

I did also try to use a drbd volume from host and it is working well, I 
can write, the Primary promotion was automatic

I think there are some communication problem with the proxmox storage 
plugin but I'm not sure, of course.

Anyway thank you for your reply!

Here the logs of the VM start on a diskless node

     New resource 'vm-101-disk-1' on node 'p6t2' registered.
     Resource 'vm-101-disk-1' on node 'p6t2' UUID is: 
     Volume with number '0' on resource 'vm-101-disk-1' on node 'p6t2' 
successfully registered
     Volume UUID is: f995230b-d95c-4745-bb6f-db974991a3f1
     Created resource 'vm-101-disk-1' on 'p6t2'
     Added peer(s) 'p6t2' to resource 'vm-101-disk-1' on 'p6t3'
     Added peer(s) 'p6t2' to resource 'vm-101-disk-1' on 'p6t1'
     Resource 'vm-101-disk-1' on 'p6t2' ready
     Node(s): 'p6t2', Resource: 'vm-101-disk-1'
kvm: -drive 
The device is not writable: Permission denied
Use of uninitialized value in join or string at 
/usr/share/perl5/PVE/Storage/Custom/LINSTORPlugin.pm line 152.

   Intentionally removing diskless assignment (vm-101-disk-1) on (p6t2).
   It will be re-created when the resource is actually used on this node.
     Node: p6t2, Resource: vm-101-disk-1 marked for deletion.
     Node: p6t2, Resource: vm-101-disk-1 UUID is: 
     Deleted 'vm-101-disk-1' on 'p6t2'
     Notified 'p6t3' that 'vm-101-disk-1' is being deleted on 'p6t2'
     Notified 'p6t1' that 'vm-101-disk-1' is being deleted on 'p6t2'
     Node: p6t2, Resource: vm-101-disk-1 deletion complete.
     Node: p6t2, Resource: vm-101-disk-1 UUID was: 
TASK ERROR: start failed: command '/usr/bin/kvm -id 101 -name prova2 
-chardev 'socket,id=qmp,path=/var/run/qemu-server/101.qmp,server,nowait' 
-mon 'chardev=qmp,mode=control' -chardev 
'socket,id=qmp-event,path=/var/run/qmeventd.sock,reconnect=5' -mon 
'chardev=qmp-event,mode=control' -pidfile /var/run/qemu-server/101.pid 
-daemonize -smbios 'type=1,uuid=f01631be-8d16-4eb6-acb8-d91957317262' 
-smp '2,sockets=1,cores=2,maxcpus=2' -nodefaults -boot 
-vnc unix:/var/run/qemu-server/101.vnc,password -cpu qemu64 -m 512 
-device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e' -device 
'pci-bridge,id=pci.2,chassis_nr=2,bus=pci.0,addr=0x1f' -device 
'vmgenid,guid=e2a1888f-adcb-42d3-98e7-b05b03277236' -device 
'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 
'usb-tablet,id=tablet,bus=uhci.0,port=1' -device 
'VGA,id=vga,bus=pci.0,addr=0x2' -device 
'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi 
'initiator-name=iqn.1993-08.org.debian:01:9504984c045' -drive 
'if=none,id=drive-ide2,media=cdrom,aio=threads' -device 
'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -device 
'virtio-scsi-pci,id=scsihw0,bus=pci.0,addr=0x5' -drive 
-machine 'accel=tcg,type=pc'' failed: exit code 1

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20190714/528792ae/attachment.htm>

More information about the drbd-user mailing list