[DRBD-user] [DRBD9] on freshly created cluster, slave does not sync with master

Zbigniew Kostrzewa kostrzewa at 9livesdata.com
Thu Sep 7 14:05:49 CEST 2017

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi all,

I am trying to setup 3-node cluster but constantly one of the nodes fail 
to sync with master. Here is what I do:

1. I create 3 VMs with CentOS 7.2 minimal (`3.10.0-327.el7.x86_64`)
2. I install DRBD9 RPMs I have built myself from following tags: drbd: 
9.0.9, drbd-utils: 9.1.0, drbdmanage: 0.99.10
3. I setup SSH passwordless authentication between all 3 nodes
4. I setup hostname and add all hostnames to /etc/hosts on each node
5. On master, I run `drbdmanage init [MASTER_IP]`
6. On each slave I run `drbdmanage add-node [SLAVE_HOSTNAME] [SLAVE_IP]`

...and what happens is that first slave synchronizes with master 
properly but the second one hangs in "Connecting" state and is marked on 
master as "StandAlone":

.drbdctrl role:Primary
   volume:0 disk:UpToDate
   volume:1 disk:UpToDate
   node-10-9-4-137 role:Secondary
     volume:0 peer-disk:UpToDate
     volume:1 peer-disk:UpToDate
   node-10-9-4-192 connection:StandAlone

According to user's guide, this should work out-of-the-box but somehow 
it doesn't. Am I missing something? Should I do some pre-setup that's 
not mentioned in the user's guide?

I've collected output from drbdadm, drbdsetup, dbus-monitor --system and 
syslog, if anyone would be willing to help me with this I have put the 
logs on github:
- master: 
- slaves:
     * successful: 
     * failing: 

Zbigniew Kostrzewa

More information about the drbd-user mailing list