[DRBD-user] 'resource' not defined in your config (for this host).

Tim Smith gb10hkzo-drbd at yahoo.co.uk
Tue Aug 12 12:34:40 CEST 2014

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.


I'm struggling with the totally incompressible and badly worded error messages in DRBD !

8.4.4-1ubuntu1 (as bundled with Ubuntu 14.04LTS)

I have tried a million different styles of config file writing and none of them work !  All of them generate the stupid error message above that doesn't tell me anything.

The nearest thing I've found to an answer on Google is a smug post in 2009 from someone who told someone else "Well, "resource" is not defined in your config, but "r0" is. Try that 
instead :)"  .... well that's a silly answer that doesn't tell me anything either !

So please, could someone tell me what I should be doing to make this work.

And yes, uname -n does return "XXX-vm02-bk01" and "XXX-vm02-bk01".  

Thank you !


$ sudo drbdadm create-md resource
'resource' not defined in your config (for this host).

$ cat /etc/drbd.d/global_common.conf
global {
        usage-count no;

common {
        net {

                protocol C;
                cram-hmac-alg "sha512";
                shared-secret "none_of_your_business";

$ cat r0.res 
resource r0 {

device minor 1;
disk /dev/raidVolgrp/raidLv;
meta-disk internal;

floating;   # Note that I have also tried with these two lines
floating;   # disabled, and the below two stanzas enabled

#on XXX-vm02-bk01 {
#       address;     # Note that I have also tried with
#        device /dev/drbd1;              # the device, disk and meta disk enabled here
#        disk /dev/raidVolgrp/raidLv;    # and disabled in the general section at the top
#        meta-disk internal;

#on XXX-vm01-bk01 {
#       address;
#        device /dev/drbd1;
#        disk /dev/raidVolgrp/raidLv;
#        meta-disk internal;


More information about the drbd-user mailing list