[DRBD-user] Can't promote to primary

David Coulson david at davidcoulson.net
Thu Aug 2 13:23:01 CEST 2012

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Provide cat /proc/drbd from both nodes. I'd guess your split brain and one node doesn't have uptodate disk. 

Sent from my iPad

On Aug 2, 2012, at 4:52 AM, "Yount, William D" <Yount.William at menloworldwide.com> wrote:

> I have a two node DRBD cluster. It is setup in Primary/Primary. Everything works good. I turned Node2 off and for some reason the IP address didn’t automatically failover, but that is an issue for another group.
> I decided to restart Node1 and the IP address did come back up on Node1. The issue now is that the although it was primary when I restarted, it came back up in Secondary. Not a big deal, I just need to promote to primary. However I keep getting this error when I run ‘drbdadm primary nfs’:
> 0: State change failed: (-2) Need access to UpToDate data
> Command 'drbdsetup 0 primary' terminated with exit code 17
> I tried looking that up but didn’t come up with anything. I am not sure why it would need up to date information if I am trying to set it to primary. Shouldn’t it just assume that the information is up to date? I have attached my configuration.
> Can anyone see any changes I need to make to my configuration that would help resolve this?
> William
> <nfs.res>
> _______________________________________________
> drbd-user mailing list
> drbd-user at lists.linbit.com
> http://lists.linbit.com/mailman/listinfo/drbd-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20120802/d9341a9d/attachment.htm>

More information about the drbd-user mailing list