[DRBD-user] 8.3.11 on RHEL 5.7 w/ MTU of 9000 fails

Digimer linux at alteeve.com
Sat Jul 23 06:30:13 CEST 2011

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi all,

  I installed from source DRBD 8.3.11 on RHEL 5.7's Xen kernel
(2.6.18-274.el5xen). I've got RHCS setup using rgmanager, but this issue
arose without rgmanager running, so I doubt it relates.

  When I have the interfaces' MTU set to 9000, the DRBD resource will
hang when bringing the second node up to Primary (dual primary config).
The attach and connect steps worked fine and the first node goes to
Primary fine.

  Interestingly enough, while debugging it, I 'ifconfig eth1 mtu 1500'
one node, and before I could do it to the second (hung) node, it was
fenced (using the obliterate-peer.sh script to tie it into the cluster).
So *some* level of communication was working. I'm guessing though that
the messages between DRBD are well below 1500 bytes though, so that
might have been the problem.

  Any way to debug this? If it looks like a DRBD bug, I'd be happy to
file a bug report, I just need to know where. :)

E-Mail:              digimer at alteeve.com
Freenode handle:     digimer
Papers and Projects: http://alteeve.com
Node Assassin:       http://nodeassassin.org
"At what point did we forget that the Space Shuttle was, essentially,
a program that strapped human beings to an explosion and tried to stab
through the sky with fire and math?"

More information about the drbd-user mailing list