[DRBD-user] DRBD Primary fails to mount resource - Need help today

Bruce Wolfe brucewolfe.sf at gmail.com
Mon Aug 1 00:03:40 CEST 2011

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Been having some trouble with a system I need now to manage after a
contractor moved out of state. Would greatly appreciate any help you can
offer this Sunday afternoon.

2-bare metal servers with:
CentOS 5.5
DRBD 8.0.13 (I know it is really old but that is what we are working with
Heartbeat 2.1.3
Zimbra 6.0 on /dev/drbd0 to be mounted as resource, repdata.

Seems that the Secondary after a physical move to a data center never got
reconnected. Heartbeat on Secondary was stopped. The Secondary was
Inconsistent for more than a month. I was able to --discard-my-data and
'connect' once again with the Primary with the expert help from 'digimer' on
IRC #drbd. She had to step away and suggested checking in with the folks at
#linux-ha but to no avail.

On that first full (re)sync, the Secondary showed up as
ds:Diskless/UpToDate. Upon several suggestions from others on IRC and forum
searches, I resync'd the Secondary again which then showed
ds:UpToDate/UpToDate. That was good. It took many hours so this morning
seeing that it was good, I restarted Heartbeat.

Now, the resource got unmounted from Primary. I tried to remount the
resource 'mount /dev/drbd0 /repdata' to no avail. Trying 'drbdadm attach
repdata' found the drbd.conf file but then terminated with an exit
error of code
10. I stopped Heartbeat on Secondary and tried to 'drbdadm attach repdata'
on Primary to no avail; same error message. Then the Secondary started to
sync with Primary so now I am waiting for it to finish before I perform any
more commands.
Here is the log file on Heartbeat doing that work unmounting the resource.

So, now /dev/drbd0 to be mounted to /repdata is not there and the Secondary
is sync'ing as SyncSource with the Primary as SyncTarget. Again, I am
waiting for the sync'ing to finish before attempting anything else.

What is going to happen when sync'ing is done?
If resource is not mounted again, what should be done to get it mounted
How can I check the integrity of the data on /dev/drbd0?

Thank you in advance for any help you may be able to offer.

Here is /etc/drbd.conf (same on both servers/nodes):
global { usage-count no; }
resource repdata {
  protocol C;
  startup { wfc-timeout 0; degr-wfc-timeout     120; }
  disk { on-io-error detach; }
  syncer { rate 40M; }
  on zimbra1.marininstitute.org {
    device /dev/drbd0;
    disk /dev/VolGroup01/LogVol01;
    meta-disk internal;
  on zimbra2.marininstitute.org {
    device /dev/drbd0;
    disk /dev/VolGroup00/LogVol00;
    meta-disk internal;

Here are the DRBD particulars on both servers:
@zimbra1 ~]# cat /proc/drbd
version: 8.0.13 (api:86/proto:86)
GIT-hash: ee3ad77563d2e87171a3da17cc002ddfd1677dbe build by
buildsvn at c5-x8664-build, 2008-10-03 10:12:56
 0: cs:SyncTarget st:Primary/Secondary ds:Inconsistent/UpToDate C r---
    ns:0 nr:290633152 dw:290632896 dr:0 al:3239339 bm:3248376 lo:9 pe:1873
ua:8 ap:0
        [===>................] sync'ed: 21.9% (1017771/1301592)M
        finish: 9:09:40 speed: 31,232 (74,064) K/sec
        resync: used:5/61 hits:18148694 misses:17743 starving:0 dirty:0
        act_log: used:0/127 hits:0 misses:0 starving:0 dirty:0 changed:0

@zimbra2 ~]# cat /proc/drbd
version: 8.0.13 (api:86/proto:86)
GIT-hash: ee3ad77563d2e87171a3da17cc002ddfd1677dbe build by
buildsvn at c5-x8664-build, 2008-10-03 10:12:56
 0: cs:SyncSource st:Secondary/Primary ds:UpToDate/Inconsistent C r---
    ns:294035776 nr:0 dw:729578912 dr:294056481 al:34 bm:99729 lo:241 pe:16
ua:240 ap:0
        [===>................] sync'ed: 22.1% (1014448/1301592)M
        finish: 3:04:46 speed: 93,692 (74,212) K/sec
        resync: used:1/61 hits:18359513 misses:17947 starving:0 dirty:0
        act_log: used:0/127 hits:104 misses:16 starving:0 dirty:0 changed:16
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20110731/0ba5f5f1/attachment.htm>

More information about the drbd-user mailing list