[DRBD-user] rolling update from 8.3.11 to 8.4.0

Junko IKEDA tsukishima.ha at gmail.com
Mon Aug 1 04:22:56 CEST 2011

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.


I tried to update Secondary node from 8.3.7 to 8.4.0 with wipe-md/create-md,
(Primary keeps running as 8.3.7)
and it succeeded.


2011/7/30 Zev Weiss <zweiss at scout.wisc.edu>:

> Hi,
> I'm attempting a rolling update from 8.3.7 to 8.4.0 (hoping it solves my
> write performance problems), and running into the same
> 'drbd_md_sync_page_io(,...s,WRITE) failed!' problem.  I have two nodes in
> primary/secondary with DRBD on top of LVM on top of md RAID10, and I get
> this on all of my DRBD resources.  I'm attempting to update the secondary,
> the primary remained active and in-use on 8.3.7 during this.
> I had initially tried it without the metadata wipe/re-create -- after seeing
> this message I retried including those steps, but it didn't change anything.
>  After the first attempt (without the wipe-md/create-md) I rolled back to
> 8.3.7 and when I re-attached my resources it appeared that the 8.4.0 upgrade
> attempt somehow nuked the metadata anyway, since 8.3.7 couldn't find a magic
> number, so I had to do a full re-sync.  Now that I've made another attempt
> and gotten the same results, it looks like I'm going to have to do that
> again.
> Anyone else seen this, or have any other advice?
> Thanks,
> Zev
> _______________________________________________
> drbd-user mailing list
> drbd-user at lists.linbit.com
> http://lists.linbit.com/mailman/listinfo/drbd-user

More information about the drbd-user mailing list