[DRBD-user] Problem with DRBD and CLVM

Digimer linux at alteeve.com
Thu Sep 9 16:18:30 CEST 2010

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi all,

  I've got a simple 2-node cluster running Red Hat cluster services.
Using cman's DLM, I've enabled CLVM and tried to use the /dev/drbd0
device as a physical volume.

  When I first called the pvcreate, it fenced the other node and then
timed out. After it came back up, I re-ran the pvcreate and it worked.
On the other node though, when I ran pvdisplay to make sure that the PV
was visible on both nodes, it showed:

  Found duplicate PV 4BbAHN2mFIP5pJsUE1ktdjSBwgFegmaG: using /dev/md3
not /dev/drbd0
  "/dev/md3" is a new physical volume of "422.44 GiB"
  --- NEW Physical volume ---
  PV Name               /dev/md3
  VG Name
  PV Size               422.44 GiB
  Allocatable           NO
  PE Size               0
  Total PE              0
  Free PE               0
  Allocated PE          0
  PV UUID               4BbAHN-2mFI-P5pJ-sUE1-ktdj-SBwg-FegmaG

  When I then tried to create a VG, it errored with:

vgcreate -c y drbd_vg0 /dev/drbd0
  Found duplicate PV 4BbAHN2mFIP5pJsUE1ktdjSBwgFegmaG: using /dev/md3
not /dev/drbd0
  Error locking on node <node name>: Command timed out
  Can't get lock for orphan PVs

  The cluster itself seems stable. That is, totem communication seems
stable (I'm not getting random fencing as I'd expect with network
issues). Any idea what might be going on?


E-Mail:         linux at alteeve.com
AN!Whitepapers: http://alteeve.com
Node Assassin:  http://nodeassassin.org

More information about the drbd-user mailing list