[DRBD-user] block-drbd script with Xen 3.4 ?

Pierre POMES pierre.pomes at interface-tech.com
Tue Jul 27 03:17:00 CEST 2010

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.


The block-drbd script does not seem to work with Xen 3.4. I am using 
this config:

disk        = [

When trying to start the DomU, I got error "Error: Device 51714 not 
connected". In xen-hotplug.log, an error is reported: 
"/etc/xen/scripts/xen-hotplug-cleanup: line 24: [: !=: unary operator 
expected". The code is :

   # if the vm path does not exist and the device class is 'vbd' then we 
may have
   # a tap2 device
   if [ $(xenstore-read "$vm_dev" 2>/dev/null) != "" ] \      #<---- 
&& [ "${path_array[1]}" = "vbd" ]; the

After some research, this error seems to be identified by the xen dev 
team, and is corrected here :

I tried the fix, I have no more error "unary operator expected", but the 
DomU does not start with still the same error 51714. The drbd backends 
are never promoted in primary state.

I am using drbd 8.3.7 (from a git clone + git checkout drbd-8.3.7 + 
dpkg-buildpackage) on Ubuntu Lucid, with the Xen 3.4 package backported 
from Debian testing.

Did anyone have success with the block-drbd script with Xen 3.4 ? It is 
working like a charm with previous version of Xen, at least Xen 3.2 in 
Ubuntu Hardy.

Many thanks !

* *

More information about the drbd-user mailing list