[DRBD-user] Sunshine screen with XenServer 5.6 FP1

Rom Zhe zherom at gmail.com
Tue Dec 21 19:59:32 CET 2010

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi guys. Have some updates and more info for you.
While trying to tackle the problem from dif. angles, I installed plain HDD
in one of the servers and put XS 5.6 FP1 on it, also
gave DRBD /dev/sda3 on the same drive. Before server booted from flash card
(perhaps not fast enough to capture crash info) and data was on RAID
This time around I was able to see what happened behind "sunshine screen"
(also got crash and other logs generated).
    <1>BUG: unable to handle kernel NULL pointer dereference at 00000004
    <1>IP: [<c01b9abc>] bio_free+0x2c/0x50
    <4>*pdpt = 00000004fe3ed027 *pde = 0000000000000000
    <0>Oops: 0000 [#1] SMP
    <0>last sysfs file: /sys/class/net/lo/carrier

I'm attaching snapshot of "OOPS" and a few log files hoping this will shed
some light on what's really causing this
and how to fix it.. As I understand this problem was confirmed by Jodok (or
maybe it's dif. issue).. Any thoughts?

On Sun, Dec 19, 2010 at 12:42 PM, Rom Zhe <zherom at gmail.com> wrote:

> Hi all,
> I spent almost 2 days trying to get DRBD working with XenServer 5.6 FP1.
> Compiled DRBD 8.3.81 and 8.3.9 on new XS DDK VM (kernel
> and at first thought everything was good..
> But after setting up 2 nodes, syncing both and getting ready to call it a
> day decided to check the speed.
> dd if=/dev/zero of=/dev/drbd1 bs=256M count=1 oflags=direct
> and... immediately got the "sunshine" screen (the one we see when XS boots
> up). Complete server lockup. No network, no kb or mouse..
> After hard reset no signs of any troubles. Server boots up just fine. logs
> don't have anything special.
> Later found out it's not just "dd" that brings up the sunshine, fdisk -l
> /dev/drbd1 and pvs also cause the same sudden freeze.
> Tried giving DRBD whole disk (/dev/sdb) or partition (/dev/sdb1) - no dif.
> if I do "service stop drbd" - all is good.
> I can fdisk or dd backing device - no problem. These servers were working
> fine with XS 5.5, 5.6 and DRBD 8.3.81, I ran multiple throughput/latency
> tests before (against /dev/drbd1) on both and all was good..
> I tried drbd device in Primary/Secondary, in primary stand alone and got
> tired of hard-resetting after each 'sunshine'.
> Exhausted all other "what if I try this" options, online searches didn't
> help much either.
> Everything points to drbd-km module and I'd like to ask if anybody have
> seen this before or has any suggestions.
> Perhaps there is something about kernel or some settings I need
> to adjust for ./configure when compiling drbd?
> While nodes are syncing - all seems good. No I/O errors, speed is about 90%
> compared to direct disk access.
> Any thoughts/ideas are greatly appreciated. Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20101221/2ee7a3a8/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: crash-reports.zip
Type: application/zip
Size: 103337 bytes
Desc: not available
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20101221/2ee7a3a8/attachment.zip>
-------------- next part --------------
A non-text attachment was scrubbed...
Type: image/jpeg
Size: 338192 bytes
Desc: not available
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20101221/2ee7a3a8/attachment.jpeg>

More information about the drbd-user mailing list