[DRBD-user] Error when trying to mount drbd partition : 'Bad geometry: block count xxx exceeds size of device'

Lars Ellenberg lars.ellenberg at linbit.com
Wed Oct 7 10:22:12 CEST 2009

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On Tue, Oct 06, 2009 at 07:14:03PM -0700, clipclop wrote:
> Running DRBD 8.3.3 on Fedora 11.

kernel version?
who compiled DRBD?

when compiling DRBD,
it "remembers" against which kernel .config it has been compiled,
does that match exactly with the .config of the running kernel?

> Had a 5.4 TB partition operating under DRBD over several months without
> problem. Just last week the server locked up and the message log started
> filling up with errors relating to the disk, mostly along the lines of :
>    EXT4-fs: bad geometry: block count 1451919360 exceeds size of device
> (1073446912 blocks)
> After rebooting the DRBD partition refused to mount (even after specifying
> the type), with the message
>   mount : type erroné de syst .de fichiers, option erronée, super bloc
>         erroné sur /dev/drbd0, codepage ou aide manquante ou autre erreur
> The partition is EXT4 and has external metadata.  This is the kind of error
> I would expect if I had used internal metadata and resized the partition,
> however, neither of these is the case.
> In desperation to access the data I bypassed DRBD and mounted the logical
> partition directly, which worked fine.
> Wanting to reactivate DRBD, I demounted the logical partition, started DRBD,
> recreated meta-data and forced the node into primary.  Same error message
> when trying to mount the partition /dev/drbd0.
> In summary : can mount the logical partition fine, but not when using the
> DRBD layer.
> Has anyone seen anything like this ? Is there something obvious I'm
> forgetting?

Any messages from DRBD or kernel in dmesg (or /var/log/messages),
while you try to mount it?

> In case it's relevant, the server disks are all running off a physical RAID
> card, and there's another regular occuring error message, but may not be
> related, as it occurs even when the DRBD service is stopped :
>   3w-9xxx: scsi4: ERROR: (0x03:0x0101): Invalid command opcode:opcode=0x4D.
> Thanks in advance,
> Simon

: Lars Ellenberg                
: LINBIT HA-Solutions GmbH
: DRBD®/HA support and consulting    http://www.linbit.com

DRBD® and LINBIT® are registered trademarks of LINBIT, Austria.

More information about the drbd-user mailing list