[DRBD-user] cannot connect primary (remains StandAlone)

Marcel Gsteiger Marcel.Gsteiger at milprog.ch
Fri Oct 2 15:53:27 CEST 2009

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi all

I'm using DRBD 8.3.2-6 on CentOS x86_64. I have a active/backup setup with 6 drbd devices, all being in the primary role on server 1, server 2 being in secondary role.

After restarting my primary server while the secondary server was online, I get this /proc/drbd on server1:

cat /proc/drbd
version: 8.3.2 (api:88/proto:86-90)
GIT-hash: dd7985327f146f33b86d4bff5ca8c94234ce840e build by mockbuild at v20z-x86-64.home.local, 2009-08-29 14:08:07
 (drbd0-2 are ok)
 3: cs:StandAlone ro:Primary/Unknown ds:UpToDate/DUnknown   r----
    ns:0 nr:0 dw:51316 dr:267907 al:140 bm:140 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:559036
 (drbd4-5 are ok again)

On the Server 2, I had status UpToDate/DUnknown and WFConnection. But trying to connect the primary using
drbdadm connect res5

So I thought, perhaps I have a Split Brain and tried to resolve it according to the manual as follows:
on secondary:
drbdadm disconnect res5
drbdadm -- --discard-my-data connect winxp_c

..now server 2 shows with cat /proc/drbd:
 3: cs:WFConnection ro:Secondary/Unknown ds:Inconsistent/DUnknown C r----
    ns:0 nr:0 dw:0 dr:0 al:0 bm:0 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:14680064

but on the primary server it's still not possible to connect, it stays in state StandAlone without giving an error message.

What's the "official way" to get out from this situation?

Thanks for any help and regards

More information about the drbd-user mailing list