[DRBD-user] drbd + 10gig network

Igor Neves igor at 3gnt.net
Fri Nov 20 18:35:56 CET 2009

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On 11/20/2009 05:01 PM, Mike Lovell wrote:
> Mike Lovell wrote:
>> Mike Lovell wrote:
>>> Igor Neves wrote:
>>>> Hi,
>>>> Are you still using software raid?
>>>> Have you tryed out using hardware raid?
>>>> The only time i had tryed out drbd with mdraid, well let's say, i 
>>>> never will try that again, from now on, we only use areca raid 
>>>> cards. Anyway, software raid it's slow, if you want to do this 
>>>> thing, buy raid controllers, the best ones are areca, 3ware and lsi 
>>>> it's bad, don't know all the others.
>>>> Cheers,
>>>> On 10/23/2009 10:40 PM, Mike Lovell wrote:
>>>>> exaggerated the problem. when the sync hangs, the drbd module is 
>>>>> almost completely unresponsive. i tried doing a pause-sync and 
>>>>> then resume-sync thinking that it would nudge the module into 
>>>>> working but the commands timeout on talking to the module. i can 
>>>>> still cat /proc/drbd but that is about it until i take down the 
>>>>> network interface and drbd detects the network change. if i then 
>>>>> bring back up the interface, drbd detects it can talk again but 
>>>>> then only syncs a couple of megabytes before stalling again. i 
>>>>> have tried every way i can think of to check the integrity of the 
>>>>> network link between the hosts and everything says they are fine 
>>>>> except for during a ping flood there will be a few out of a couple h
>>> yes, i am using software raid. i guess i didn't try changing that 
>>> during my hardware changes. i'll see if i can scrounge up some raid 
>>> controllers to test this with.
>> i got a hold of a few 3ware controllers and used these for the disk 
>> array instead of the software raid. unfortunately, it still broke.
> after much more experimentation and buying new hardware, i got a 
> things working. i did eventually try doing this on the hardware i had 
> using opensuse 11.2 and centos 5.4. same problems. luckily, i was able 
> to convince my boss to let me buy some new 10 gig nics cause those are 
> the only thing that didn't change. i ordered some cards from chelsio 
> (pcie, dual port cx4) and just got them on wednesday. put them in, 
> configure them, and start syncing. never hiccuped. so, i guess for 
> anyone else wanting to try this, avoid using 10gig pcie intel nics.
> mike


Can you please give me the exact Part-Number of the Cards that work from 

And by the way the exact Model/Part-Number from intel, the ones that 
don't worked?


Igor Neves<igor.neves at 3gnt.net>
3GNTW - Tecnologias de Informação, Lda

  SIP: igor at 3gnt.net	JID: igor at 3gnt.net
  ICQ: 249075444		MSN: igor at 3gnt.net
  TLM: 00351914503611	PSTN: 00351252377120

More information about the drbd-user mailing list