[DRBD-user] drbd8 and ubuntu 9.10 == :(

Andrew Barringer abarringer at bsecure.com
Tue Nov 3 21:43:59 CET 2009

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

I just tried it on four boxes w/o module-assistant. It failed on three
that are 64bit server. But it worked on 1 that was 32 bit desktop.


Did you try it on 64bit server?





From: Mike Lovell [mailto:mike at dev-zero.net] 
Sent: Tuesday, November 03, 2009 2:42 PM
To: Andrew Barringer
Cc: Lars Ellenberg; drbd-user at lists.linbit.com
Subject: Re: [DRBD-user] drbd8 and ubuntu 9.10 == :(


i just installed drbd8 on a ubuntu 9.10 box. i specified installing
drbd8-source when i installed drbd8-utils and it worked fine. i will
point out though that the drbd8-source package is broken when using
module-assistant. it doesn't put stuff in the right directory or doesn't
symlink it right. i skipped using module-assistant and built and
installed the module out of the sources provided by drbd8-source.


Andrew Barringer wrote: 

Thanks for the Classic linux help aka: you are st00pid go bug off and
For what's it's worth...
The problem was submitted weeks ago to dkms bug list and it was punted
to the drbd8 list and there's been no update from that team.
I thought it obvious that I would have tried what it suggests.
Okay... I'll go away now as directed.
-----Original Message-----
From: drbd-user-bounces at lists.linbit.com
[mailto:drbd-user-bounces at lists.linbit.com] On Behalf Of Lars Ellenberg
Sent: Tuesday, November 03, 2009 2:29 PM
To: drbd-user at lists.linbit.com
Subject: Re: [DRBD-user] drbd8 and ubuntu 9.10 == :(
On Tue, Nov 03, 2009 at 02:02:23PM -0600, Andrew Barringer wrote:

	On a clean install of 9.10 I run the following 
	apt-get install linux-headers-server
	apt-get install drbd8-utils
	Following are the results... what should I do?


	Adding [drbd8-8.3.3] Module to DKMS build system
	ERROR: Missing kernel headers.
	You appear to have at least some kernel headers
	installed, but you do not have the necessary
	headers to build drbd8-source against this kernel.
	You might try installing the meta package:
	 $ sudo apt-get install linux-headers-server
	or specifically
	 $ sudo apt-get install linux-headers-2.6.31-11-server
	to obtain the necessary build dependencies.

do as it suggests?
if installing linux-headers-2.6.31-11-server
does not help, complain to the ubuntu package maintainers
of drbd, dkms, or both.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20091103/8da87115/attachment.htm>

More information about the drbd-user mailing list