[DRBD-user] block-drbd and Xen

Jerry Amundson jamundso at gmail.com
Tue Sep 2 04:31:21 CEST 2008

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On Mon, Sep 1, 2008 at 8:25 PM, Alexandre Biancalana
<biancalana at gmail.com> wrote:
> Hi list,
>  I know that this subject was discussed before but I don't find any
> definitive answer to this question, so I hope that this message can
> help people finding this in future.

Doesn't matter. Most people seem to find the *official* answer, which
*official* people refuse to change, yet many times just does not work.

>  I installed Debian 4 (etch), Xen 3.2 and DRBD 8.0.13 (from
> backports).  The objective is to build a two-node Linux HA to
> virtualize some legacy services and development machines.
>  My question is about block-drbd script, when I try to boot a virtual
> machine using a drbd disk resource like this:
> disk   = [ 'drbd:app01,hda,w' ]

Why did you use that?

> I get a lot of errors in the virtual machines, windows 2k gives the message:
>  disk i/o error: Status = 00000c00
>  Setup cannot access this disk


> When I use the drbd device directly:
> disk    = [ 'phy:/dev/drbd0,hda,w' ]
>  everything works great, but I don't want to write wrapper scripts to
> handle live migration.

Of course phy: works great. Fortunately, with allow-two-primaries;,
and other controls, DRBD 8.x can do Xen live migration, even using
phys: ...

> I already tried to do this setup with Cent5 too but the error is the
> same and the people at centos-virt list say the this only work with
> Xen > 3.1, I tried to see if block-drbd script changes between 8.0.13
> and 8.2.6, but the script is the same.

Hmm. Maybe this is new with Debian, because of (etch) anyway...


There's plenty of youth in America - it's time we find the "fountain of smart".

More information about the drbd-user mailing list