[DRBD-user] ERROR: Module drbd is in use

Tom Brown brown at esteem.com
Fri Mar 7 19:57:08 CET 2008

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.


I am experiencing an inconsistent error when I run 

/etc/init.d/drbd stop

Here's what I see:

tbrown at fs01:~$ sudo /etc/init.d/drbd stop
Stopping all DRBD resourcesERROR: Module drbd is in use

Then the drbd module is left loaded. However, I can run

sudo rmmod drbd

just after that and it unloads the module without a problem.

I decided I could work around this problem by modifying the drbd init
script a little. I just have the script retry unloading the module if it
fails initially. It retries in a loop until it succeeds or fails five
times. I've only seen it fail up to two times on a given 'stop' command.

I am concerned that this may be indicative of a bigger problem. I saw
one post from 12/18/2007 that had the same error, but I didn't see any
solutions. Any ideas on what the problem is?


Hardware: 2 Dell PowerEdge SC1435's
OS: Debian Etch 4.0r3
Kernel: vanilla kernel
DRBD: 8.2.5

global {
    usage-count yes;

common {
  syncer { rate 115M; }

resource r0 {
  protocol C;
  handlers {
    pri-on-incon-degr "echo o > /proc/sysrq-trigger ; halt -f";
    pri-lost-after-sb "echo o > /proc/sysrq-trigger ; halt -f";
    local-io-error "echo o > /proc/sysrq-trigger ; halt -f";
    outdate-peer "/usr/lib/heartbeat/drbd-peer-outdater -t 5";
  startup {
    wfc-timeout  20;
    degr-wfc-timeout 120;
  disk {
    on-io-error   detach;
  net {
    after-sb-0pri disconnect;
    after-sb-1pri disconnect;
    after-sb-2pri disconnect;
    rr-conflict disconnect;
  syncer {
    al-extents 257;
  on fs01 {
    device     /dev/drbd0;
    disk       /dev/sdb1;
    meta-disk  /dev/sda2 [0];
  on fs02 {
    device     /dev/drbd0;
    disk       /dev/sdb1;
    meta-disk  /dev/sda2 [0];

More information about the drbd-user mailing list