[DRBD-user] DRBD, MPT SAS - very slow after 2GB of writing

Felix drbd at dimedis.de
Fri Sep 21 15:15:09 CEST 2007

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hello List,

I have a strange problem with DRBD on my FSC 64Bit servers.

Here is what I use (I tried Debian Stable standard kernel and drbd
module source at the beginning. Makes no difference)

Debian Stable drbd0.7-utils
drbd-0.7.24 kernel module
Linux 2.6.21-2-amd64

One server has two CPUs and 4GB RAM, the other one 1 CPU and 2GB RAM.

The rest of the hardware is identical. DRBD linked together via cross over.

There is a MPT SAS RAID Controller in the system...
05:05.0 SCSI storage controller: LSI Logic / Symbios Logic SAS1068 PCI-X
Fusion-MPT SAS (rev 01)

At the beginning, I configured a RAID 1 with this controller. It seems
well enough supported.

My little test:

I have a .tar.gz with 2GB, which resulted in 3,5GB not to many large files.

On a non DRBD Partition, I needed 4min to unpack this archive. Which is
quit bad, but not horrible.

I configured DRBD (in the beginning with defaults. Sync rate 50M.).

First, everything seems ok. But then I realized the following:

While unpacking the test archive, the following happened:

- The first ca. 2GB unpacked really fast. Suddenly it gets slower and
slower. At the end, I saw a write rate of 2MB/sec and LESS.

It took more then 20min (!) to unpack the archive...

I didn't believe my eyes. So I tried this and that. Finally I disabled
the MPT SAS Raid 1 in the Controller BIOS on both machines.

Now it took less then 3min to unpack the test archive.
(DRBD alone is faster, then a local MPT SAS RAID 1!)

Now I am curious: Is there any special problem with this (or any) RAID
controller and DRBD? Perhaps the RAID controller is simply trash and I
better use Linux Softraid?

Probably its stupid to use a local RAID 1 AND a DRBD Raid 1 in conjunction?


More information about the drbd-user mailing list