[DRBD-user] VolGroups dissapeared

James Wilson jwilson at transolutions.net
Thu Sep 13 15:13:53 CEST 2007

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Well it seems the partitions are back I did the same thing I did last 
night and now I see everything. Any idea as to what happend. Because 
this would've been pretty scary for production. If you need any other 
information just let me know. Thanks in advance.

James Wilson wrote:
> Yesterday I was testing failover with rhcs5 and drbd. To test failover 
> I simply unplugged the network cable from the server. The IP failed 
> over like it was supposed and all the data was still there also. But 
> when I brought the other server back on line it came up in a 
> Secondary/Unknown state and when I did an lvscan the logical volume 
> wasn't there anymore. So I tried setting the server to drbdadm primary 
> all and activating the volume group "vgchange -a y VolGroup02". Still 
> no logical volume. Which was ok because I still had the volume on the 
> other server because of failover. Well the other server was still 
> reading Primary/Unknown also. So I tried bringing drbd down and back 
> up by unmounting and drbdadm down all. Then I reset the services and 
> brought everything back up. Both server were still reading 
> Secondar/Unknown but now the logical volume on the failover server was 
> gone also. Has this happend to any one? Did I configure something 
> wrong the servers were set for Primary/Primary and running a gfs2 file 
> system.
> _______________________________________________
> drbd-user mailing list
> drbd-user at lists.linbit.com
> http://lists.linbit.com/mailman/listinfo/drbd-user

More information about the drbd-user mailing list