[DRBD-user] Re: mkfs stays in uninterruptible sleep

Arne Altrichter arne at meteo-graphics.de
Wed Nov 21 08:55:59 CET 2007

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi Lars,

thank you!
I already found that solution, after spending some time searching the 
mailing list. I'm not that experienced with mailing lists and don't like 
them very much...

8.0.7 fixed it.


Lars Ellenberg wrote:
> since you are not subscribed, your post had been held back.
> with the amount of spam received, and other things to do,
> moderation of held posts is staying behind a bit.
> so sorry for the late let-through and reply.
> On Fri, Nov 16, 2007 at 01:16:58PM +0100, Arne Altrichter wrote:
>> Hi,
>> I'm trying to make a filesystem on top of a drbd device, but the mkfs 
>> process never finish. Its the same with mkreiserfs and mkfs.xfs. I tried 
>> to make a 10G drbd device and it works, but its not working with devices 
>> larger than 25G.
>> The last mkreiserfs message is:
>>        ALL DATA WILL BE LOST ON '/dev/drbd0'!
>> Continue (y/n):y
>> Initializing journal - 0%....20%....40%....60%....80%....100%
>> "
>> Its possible to mount the faulty created filesystem, but fsck.reiserfs 
>> suggests to run --rebuild-tree. --rebuild-tree also results in an 
>> "uninterruptible sleep" process.
>> Drbd 0.7 don't make a difference. Creating a filesystem directly on the 
>> raid without drbd works fine.
> that it would not work with 0.7.25 I can't believe.
> that it could hang with drbd <= 0.7.24, and kernel >= 2.6.22
> is known, and fixed, thats why we have 0.7.25.
>> specs:
>> OS: Ubuntu Feisty Server
>> Kernel: 2.6.22-14-server #1 SMP Sun Oct 14 22:09:15 GMT 2007 x86_64 
>> GNU/Linux
>> DRBD: version: 8.0.3 (api:86/proto:86), SVN Revision: 2881 build by 
> same here,
> please try again with 8.0.7 respectively 8.2.1.

More information about the drbd-user mailing list