[DRBD-user] Drbd ocfs2

James Miller jimm at simutronics.com
Sat Jul 21 00:10:49 CEST 2007

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

> -----Original Message-----
> From: drbd-user-bounces at linbit.com 
> [mailto:drbd-user-bounces at linbit.com] On Behalf Of Pierguido
> Sent: Thursday, July 19, 2007 11:22 AM
> To: drbd-user at linbit.com
> Subject: Re: [DRBD-user] Drbd ocfs2
> I finally managed to solve the problem with drbd...now 
> everything works as primary/primary and with ocfs2 fs on it.
> I just noticed one thing...u tried to shutdown one node and 
> then to write something in the other node...start again the 
> other node and check if they were ri-sync.
> But i saw that the second node went up with the drbd set secondary:
> cluster-2:/home/pier# cat /proc/drbd
> version: 8.0.4 (api:86/proto:86)
> SVN Revision: 2947 build by root at cluster-2, 2007-07-17 20:13:16
>  0: cs:Connected st:Secondary/Primary ds:UpToDate/UpToDate C r---
>     ns:0 nr:25734 dw:25734 dr:0 al:0 bm:20 lo:0 pe:0 ua:0 ap:0
>         resync: used:0/31 hits:1681 misses:15 starving:0 
> dirty:0 changed:15
>         act_log: used:0/257 hits:0 misses:0 starving:0 
> dirty:0 changed:0
> Now if i change it to primary (drbdadm -- 
> --overwrite-data-of-peer primary mail) and mount the fs 
> everything is ok.
> Why the drbd is not set already with primary?
> Thanks
> pier
> --

I've run into the same issue.  
1. node2 - unmount my ocfs2 partition
2. node2 - stop ocfs2
3. node2 - stop drbb
4. create/copy a file on the ocfs2 partition on node1
5 restart drbd on node2
6. node2 - cat /proc/drbd
version: 8.0.3 (api:86/proto:86)
SVN Revision: 2881 build by root at seldon, 2007-06-21 13:08:20
 0: cs:StandAlone st:Primary/Unknown ds:UpToDate/DUnknown   r---
    ns:7084389 nr:169350 dw:6201681 dr:1880135 al:1481 bm:178 lo:0 pe:0 ua:0
        resync: used:0/31 hits:65704 misses:88 starving:0 dirty:0 changed:88
        act_log: used:0/257 hits:1801252 misses:1704 starving:0 dirty:223
7. node2 - drbdadm state all
8. From here I don't know what to do to bring everything back into a good

I've tried, on node2, drbdadm -- --discard-my-data connect all w/out
success.  I still get, on node2 Secondary/unknown


More information about the drbd-user mailing list