[DRBD-user] DRBD on FC4 2.6.15-1.1831_FC4smp

Brenton Rothchild brentonr at dorm.org
Fri Mar 17 22:11:52 CET 2006

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

I guess I sent my question to the list too soon... I removed Neil Brown's
patch from FC4's 2.6.15-1.1833_FC4 kernel and have tested it quite
successfully with DRBD 0.7.17 (svn rev. 2123) under both UP and SMP.

It seems Neil Brown's patch was the issue, for me at least, in solving
the mkfs hangs.

Hope this helps anybody still having problems under FC4 :)

-Brenton Rothchild

-------- Original Message --------
Subject: Re: [DRBD-user] DRBD on FC4 2.6.15-1.1831_FC4smp
Date: Fri, 17 Mar 2006 08:35:43 -0600
From: Brenton Rothchild <brentonr at dorm.org>
To: drbd-user at lists.linbit.com
References: <4404807F.30501 at dialin.co.uk>	<200603010039.44487.lists at seattleserver.com>	<44056B02.3000101 at atosorigin.com> 
<200603041304.18589.lists at seattleserver.com>

Casey Allen Shobe wrote:
> On Wednesday 01 March 2006 09:36, Markus Marquardt wrote:
>> Casey Allen Shobe wrote:
>>>> Filesystem:
>>>> xfs on ~70 Gig drbd device
>>> Does the Fedora Core kernel use 4k kernel stacks?  I think it does.  If
>>> so, using XFS on DRBD can be expected to be broken.
>> Yes, FC4 is using CONFIG_4KSTACKS. But when going for building a new
>> kernel from vanilla sources, there is no CONFIG_4KSTACKS option
>> anymore.
>> Does this mean 4K stacks are now always used? Have i explicitly to
>> specify CONFIG_4KSTACKS=n in .config?
> No, they're disabled per default.  They are only available as a choice at all 
> in the kernel hacking section if you enable experimental/unsafe options.
> Cheers,

Does CONFIG_4KSTACKS=n fix the hang issues on FC4 in general?  Or
is there still some issue with the infamous "Neil Brown" patch?

I'm curious because I still get hangs with mkfs under FC4 kernels
(I've tried 2.6.15-1.1831_FC4 and 2.6.15-1.1833_FC4, both UP and SMP, all i686),
using DRBD 0.7.16 (svn rev. 2088) and DRBD 0.7.17 (svn rev. 2123).

Is there any resolution to mkfs hangs under FC4 while still
using FC4 kernels? :)

I'm happy to provide any additional information that might be
needed to figure out what's going on.

-Brenton Rothchild
drbd-user mailing list
drbd-user at lists.linbit.com

More information about the drbd-user mailing list