[DRBD-user] drbdsetup hangs forever with drbd 0.7.x

Lars Ellenberg Lars.Ellenberg at linbit.com
Mon Jun 20 13:26:25 CEST 2005

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

/ 2005-06-20 12:01:42 +0200
\ Jens Viebig:
> Hello List,
> i'm trying to get drbd 0.7 working with SuSE 8.2 and the default 2.4 Kernel
> on an IBM eServer x346.
> The 'drbd' disk is an external sata raid device connected over scsi cable.
> When i run drbdsetup
> drbdsetup /dev/drbd0 disk /dev/sdb2 /dev/sdb1 0
> or
> drbdsetup /dev/drbd0 disk /dev/sdb2 internal -1
> It just hangs forever, i even can't abort it (with ctrl-c) or kill
>  (kill -9 ) the process.
> The last message i get from drbd in the log says:
> Jun 20 11:18:28 suse82 kernel: drbd0: drbdsetup
> [11288]:drbd_md_sync_page_io(,488033528,READ)
> I tried a lot of versions form 0.7.0 to 0.7.11 but all show the same
> behaviour
> I got drbd runing fine with 0.6.13 on that machine. I like to use 0.7
> because of its support for XFS filesystem and the process of synching seems
> to be more 'intelligent' than with 0.6 which does matter because our disks
> in production will be quite big (around 2 TB)
> Any idea why drbdsetup with 0.7 hangs ??

maybe it is just very slow during the initial creation of the bitmap...
that is not optimized at all, and creates the bitmap and other meta data
using synchronous sector-sized io...

experiment with a small (few GB) device first.
large (some TB) devices may be very slow during (initial) setup.

: Lars Ellenberg                                  Tel +43-1-8178292-0  :
: LINBIT Information Technologies GmbH            Fax +43-1-8178292-82 :
: Schoenbrunner Str. 244, A-1120 Vienna/Europe   http://www.linbit.com :
please use the "List-Reply" function of your email client.

More information about the drbd-user mailing list