[DRBD-user] kernel oops while syncing

Lars Ellenberg lars.ellenberg at linbit.com
Fri Nov 20 19:13:26 CET 2009


On Thu, Nov 19, 2009 at 02:39:17PM +0100, Johan Euphrosine wrote:
> On Thu, 2009-11-19 at 13:53 +0100, Lars Ellenberg wrote:
> > 
> > No. That one is something different,
> > and most likely you simply screwed up the compilation.
> > drbd compiles without warnings.
> > if you get compilation warnings,
> > you got some compatibility define wrong. 
> > 
> 
> Hi,
> 
> I backported drbd8-8.3.4-1 from debian/sid to squeeze using the
> following commands:
> dget http://ftp.de.debian.org/debian/pool/main/d/drbd8/drbd8_8.3.4-1.dsc

those packages are _broken_ in the sense that they explicitly do NOT
call our auto "adjust_drbd_config_h.sh" magic script.

So they may or may not be compatible with your currnet kernel,
depending on whether or not the "default" compat defines fit,
or not.

We are working with the maintainers on resolving this "the debian way".

-- 
: Lars Ellenberg
: LINBIT | Your Way to High Availability
: DRBD/HA support and consulting http://www.linbit.com

DRBD® and LINBIT® are registered trademarks of LINBIT, Austria.
__
please don't Cc me, but send to list   --   I'm subscribed


More information about the drbd-user mailing list