[DRBD-user] drbd and kernel 2.6.23-rc3

Tom Brown brown at esteem.com
Sat Aug 25 01:06:43 CEST 2007


Hi,

We need to use kernel 2.6.23-rc3 to do backups to a usb drive. Earlier kernels 
were not working. I have not tried 2.6.22 yet. Has anyone tried compiling 
drbd against 2.6.23-rc3? Here are the errors I get:

/usr/src/drbd-8.0.5/drbd/drbd_main.c:1927: warning: ârequest_queue_tâ is 
deprecated
/usr/src/drbd-8.0.5/drbd/drbd_main.c: In function âdrbd_create_mempoolsâ:
/usr/src/drbd-8.0.5/drbd/drbd_main.c:2166: error: too many arguments to 
function âkmem_cache_createâ
/usr/src/drbd-8.0.5/drbd/drbd_main.c:2172: error: too many arguments to 
function âkmem_cache_createâ
/usr/src/drbd-8.0.5/drbd/drbd_main.c: In function âdrbd_cleanupâ:
/usr/src/drbd-8.0.5/drbd/drbd_main.c:2235: warning: ârequest_queue_tâ is 
deprecated
/usr/src/drbd-8.0.5/drbd/drbd_main.c:2309: error: void value not ignored as it 
ought to be
/usr/src/drbd-8.0.5/drbd/drbd_main.c: In function âdrbd_new_deviceâ:
/usr/src/drbd-8.0.5/drbd/drbd_main.c:2319: warning: ârequest_queue_tâ is 
deprecated
make[2]: *** [/usr/src/drbd-8.0.5/drbd/drbd_main.o] Error 1
make[1]: *** [_module_/usr/src/drbd-8.0.5/drbd] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.23-rc3'
make: *** [kbuild] Error 2

If drbd doesn't work with 2.6.23-rc3 I can try other kernels. If I have just 
done something wrong, please let me know.

Thanks,
Tom



More information about the drbd-user mailing list