[DRBD-user] DRBD installation problems

Alex Vrenios alex at DSRLab.com
Tue Mar 1 00:17:09 CET 2005


Hi,

I just posted an answer to the same question, because I had the same problem
and solved it. (At least I think I did!)

First, I have 0.7.10 on a Redhat 9 pair and I dedicated two 4G drives to
DBRD, one added to each PC at /dev/hdd. I made two partitions on each: 3G
and 1G defined as /dev/hdd1 and /dev/hdd2, respectively. Then I issued:

root# drbdsetup /dev/drbd0 disk /dev/hdd1 /dev/hdd2 1

where /dev/hdd1 is my "resource file" that I want DRBD to mirror, dev/hdd2
is the "meta data" file that DRBD uses to track mirroring, and 1 (the number
one) is the index number that seems to work. (Someone here recommended using
-1,but that was an invalid choice according to the drbdsetup command. 1
works, but 2 doesn't - I have no idea what this means.)

More (not all) info on meta data file sizes and use can be found in the man
page for drbdsetup: "man drbdsetup" works on my PC under RH9.

Finally, after the drbdsetup command above, I issue:

   root# mkfs -b 3072 /dev/drbd0

   root# cd /; mkdir /data 

   root# mount /dev/drbd0 /data

   root# chmod 777 /data

After these commands, I add "/etc/init.d/drbd   start" to my rc.local

>From then on, my application user id can access and write data to the /data
area on the primary machine, and it is mirrored to my backup PC.

DISCLAIMER: I am still trying to figure out DRBD, especially the .conf file
entries, so I am by no means an expert. The above worked for me...

Alex

-----Original Message-----
From: drbd-user-bounces at lists.linbit.com
[mailto:drbd-user-bounces at lists.linbit.com] On Behalf Of Luis Eduardo Vivero
Peña
Sent: Monday, February 28, 2005 11:28 AM
To: drbd-user at lists.linbit.com
Subject: [DRBD-user] DRBD installation problems


Hi guys,


I'm traying to configure DRBD under Debian GNu/Linux 3.1 (what difficult
letters combination to remember... :) ) and I have readed the documentation.

I have compiled (drbd-0.7 from official sources) and charged the drbd module
(modprobe drbd) without problems (but the documentation is a little wrong).
This specify that I must to configure the device with the following
command:

drbdsetup /dev/nb0 disk /dev/hda4

and it's answer me:

disk lower_dev meta_data_dev meta_data_index [{--size|-d} val]
         [{--on-io-error|-e} val]
Not enough arguments.

The message is clear, but I don't know what is the parameters 'lower_dev',
'meta_data_dev' and 'meta_data_index'.


I was looking for in google but I cannot find the solution.
Can you gave me a light please?



--
Luis Eduardo Vivero Peña
Corporación Linux S.A.
www.corplinux.cl

_______________________________________________
drbd-user mailing list
drbd-user at lists.linbit.com
http://lists.linbit.com/mailman/listinfo/drbd-user






More information about the drbd-user mailing list