[DRBD-user] kernel oops

Philipp Reisner philipp.reisner at linbit.com
Fri Mar 19 10:02:17 CET 2004


Hi Kees,

I just tried to reproduce this, but I failed...
What I did:

Intentionally I set up everything, so that a resouce has to be started
from uml1 to uml2. 

uml2:~/d# /sbin/drbdsetup /dev/nbd/0 primary
ioctl() failed: No such device or address
Device not configured
uml2:~/d# /sbin/drbdsetup /dev/nbd/0 disk /dev/ubd/1 /dev/ubd/1 -1 
--on-io-error=detach
uml2:~/d# /sbin/drbdsetup /dev/nbd/0 primary
uml2:~/d# /sbin/drbdsetup /dev/nbd/0 net 192.168.22.12:7788 192.168.22.11:7788 
C --ping-int=10 --connect-int=10 --timeout=60
uml2:~/d# /sbin/drbdsetup /dev/nbd/0 syncer --group=1 --rate=4M

uml1:~/d# drbdadm up drbd0


> > I have no idea if this is the result of building it monolithic or not,
> > but the instant I tried to run "mke2fs" on the configured /dev/nb0, I hit
> > this BUG assert.
> >
> > Which lands in lc_get, on
> >
> >         BUG_ON(!lc->nr_elements);
>
> Tracked this down: this is what I get for reading 0.6 docs when using 0.7.
> If you set a device to "primary" before starting the syncer, this results.
> It should probably be handled more gracefully, though...  ;)
>

Of course :)

> This is caused by al_extents not getting configured, I guess.
>

Hmmm, al_extents gets configured as soon as the device is associated
with its backing storage.

> (I'll stick to using the init scripts now...)

May I ask you how you used drbdsetup/drbdadm to get it to crash on 
this BUG_ON() ? 

-Philipp
-- 
: Dipl-Ing Philipp Reisner                      Tel +43-1-8178292-50 :
: LINBIT Information Technologies GmbH          Fax +43-1-8178292-82 :
: Schönbrunnerstr 244, 1120 Vienna, Austria    http://www.linbit.com :



More information about the drbd-user mailing list