[Csync2] latest csync2 rpmbuild failing on centos 5.4 with error: gnutls>=2.6

Lars Ellenberg lars.ellenberg at linbit.com
Tue Jan 3 15:26:02 CET 2012

On Tue, Jan 03, 2012 at 07:35:00PM +0530, Samba wrote:
> Hi,
> I just pulled the latest changes of from git and tried to build the rpm but
> faced with an error that it requires gnutls >=2.6, which looks like a newly
> added requirement.
> I'm using centos-5.4 and the version of gnutls that is available on centos
> 5 is  : 1.4.1-3
> I found that the latest version of gnutls (version 2.8+) is only available
> on centos6 but unfortunately we cannot upgrade our OS to centos6 as of now.
> What options do I have to build the csync2 rpm from latest sources on
> centos5? could someone provide any alternate yjum update repos where the
> gnutls>=2.6 is available or any other suggestions that can unblock me from
> this stalemate?

--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,7 @@ AC_ARG_ENABLE([gnutls],
 if test "$enable_gnutls" != no
-   PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 2.6.0], [
+   PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.4.0], [
       AC_DEFINE([HAVE_LIBGNUTLS], 1, [Define to 1 when using GNU TLS library])

Probably the requirement is just bogus.  It used to be >= 1.0, iirc, but at
some point was changed to something more recent, because the old versions have
been said to be known buggy in some way.

Try to get away with what you have, I see no reason why it should not work.

: Lars Ellenberg
: LINBIT | Your Way to High Availability
: DRBD/HA support and consulting http://www.linbit.com

More information about the Csync2 mailing list