[DRBD-user] drbd does not find metadata any more

Michael Schwartzkopff ms at sys4.de
Thu Nov 26 15:23:55 CET 2020

On 26.11.20 15:17, Roland Kammerer wrote:
> On Thu, Nov 26, 2020 at 01:08:40PM +0100, Michael Schwartzkopff wrote:
>> Hi,
>> I tried to upgrade from CentOS 8.0 to 8.1. My installation has a
>> self-compiled DRBD-9.
>> After the upgrade my drbd does not start any more. the Status says:
>> # drbdadm status
>> r0 role:Secondary
>>   disk:Diskless
>>   dev02 connection:StandAlone
>> Trying to attach to the disk tells me:
>> # drbdadm attach r0
>> 1: Failure: (119) No valid meta-data signature found.
>>         ==> Use 'drbdadm create-md res' to initialize meta-data area. <==
>> Command 'drbdsetup attach 1 /dev/vgDev01/drbd /dev/vgDev01/drbd
>> internal' terminated with exit code 10
>> The journal says:
>> Nov 26 13:05:09 dev01.sys4.de kernel: drbd r0/0 drbd1: meta-data IO
>> uses: blk-bio
>> Nov 26 13:05:09 dev01.sys4.de kernel: drbd r0/0 drbd1: ambiguous node
>> id: meta-data: 1, config: 0
> Is the right module loaded?


> Did you change the res file?

Initially no, but see more below.

> Did the host names change in any way?


> Did you actually specify a node-id in the res file?

Initially no, but now yes.

> All in all the quick way out would most likely be:
> - double check the right drbd9 module is loaded.
> - add a node-id for every host to the res file on all nodes. If possible
>   the same ID/host combination on all nodes :).
> - create-md on all sides
> - start an initial sync or if you are certain enough that everything was
>   fine, skip the initial sync.

Solved the problem. In the logs the message was clear:

drbd r0/0 drbd1: ambiguous node id: meta-data: 1, config: 0

comparing the node_id from the drbdsetup show with the node_id from
drbdadm dump-md showed that the node_ids were different indeed. So I
added the node_id from the meta-data to my config and unloaded / loaded
my kernel module.

After that attaching the disk was no problem. Everything works again.

Please do not ask me, how my machine managed to mix up the node_ids. No

Thanks for your thoughts.

Mit freundlichen Grüßen,


[*] sys4 AG
https://sys4.de, +49 (89) 30 90 46 64
Schleißheimer Straße 26/MG,80333 München
Sitz der Gesellschaft: München, Amtsgericht München: HRB 199263
Vorstand: Patrick Ben Koetter, Marc Schiffbauer, Wolfgang Stief
Aufsichtsratsvorsitzender: Florian Kirstein

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20201126/3b21898b/attachment-0001.pgp>

More information about the drbd-user mailing list