[DRBD-user] Error message: Failed to create meta-data for DRBD volume

Daniel Ulman dulman at sacme.com.ar
Thu May 16 21:38:23 CEST 2019

Hi Robert,

The message:

	'vm-100-disk-1' not defined in your config (for this host)

Appear only on the combined controller + satellite node, when I run:

	drbdadm dump vm-100-disk-1

If I run:

	drbdadm dump vm-100-disk-1 -c /var/lib/linstor.d/vm-100-disk-1.res

The output of that command is fine.

On the others satellites, the first command run fine.

Any command for drbdadm (adjust, cstate, etc.) say:

	no resources defined!

If I run it without the '-c /var/lib/linstor.d/vm-100-disk-1.res' option.



-----Mensaje original-----
De: drbd-user-bounces at lists.linbit.com [mailto:drbd-user-bounces at lists.linbit.com] En nombre de Robert Altnoeder
Enviado el: lunes, 13 de mayo de 2019 12:50
Para: drbd-user at lists.linbit.com
Asunto: Re: [DRBD-user] Error message: Failed to create meta-data for DRBD volume

On 5/10/19 5:26 PM, Daniel Ulman wrote:

> 'vm-100-disk-1' not defined in your config (for this host) 

Resources were found in files included by the drbd.conf configuration
file, but none of the resources had an "on" section where the name of
the node as it is registered in the LINSTOR controller database matches
the nodename of the node as it is displayed by the command 'uname -n'.

On 5/8/19 8:24 PM, Daniel Ulman wrote:

> Yes, drbdadm always say:
>     no resources defined!

This is a different problem. Are we talking about the same system? I
thought it said "... not defined in your config ...".
This error message appears if the drbd.conf file was found, but neither
the drbd.conf file nor any of the files that were found because they
matched an "include" statement in the drbd.conf file contained a
"resource" statement.

Have all the usual problem sources been checked for both, the
interactive execution of drbdadm as well as the execution of drbdadm by
the LINSTOR satellite, e.g.:
- Is there more than one drbdadm installation in different directories?
- Does the PATH environment variable match?
- What is the security context (user/group id, supplemental groups,
POSIX capabilities, SELinux domain) of the processes?
- What are the access permissions of the files and directories
(permission bits, ACLs, SELinux type)?
- Is SELinux strict/targeted enforcing/permissive/disabled?
- Are there any other additional security mechanisms (like e.g.
AppArmor) active?
- Are the /etc/drbd-84.conf, /etc/drbd-90.conf, /etc/drbd.conf files or
symbolic links present?
- Are the files in include paths stated in drbd.conf (or elsewhere)
actually found by drbdadm?
- Do the resource names and node names match between LINSTOR and any
manual commands, and between LINSTOR and the system configuration?

This is not a comprehensive list of all possibilities, but you get the idea.

Another option is to trace what drbdadm is actually doing, e.g. by using
tools like strace to see which files are opened and/or read by drbdadm.


drbd-user mailing list
drbd-user at lists.linbit.com

More information about the drbd-user mailing list