[DRBD-user] Linstor/DRBD9 : Initial sync stuck at 30Mbps

Julien Escario julien.escario at altinea.fr
Mon May 6 14:49:06 CEST 2019

Sorry if this as already been answered : I check the archives and found
similar issues with DRBD8 but none with linstor and DRBD9.

This is not really a 'problem' but more a config/performance misconfig :
when I 'move' a ressource from another storage backend to linstor
storage on Proxmox, the sync is maxed at 3MB/s (completely flat).

Drbdtop reports this :
Sent: total:23.8MiB Per/Sec:3.0MiB

Let me first confirm my hardware is (hopefully) capable of doing far
more (10Gbps network and full SSD ZFS storage with nvme cache).

So it seems I made a misconf somewhere.

I tried to change a few values :
# linstor controller drbd-options   --max-buffers=36864
--rcvbuf-size=2097152   --sndbuf-size=1048576
# linstor controller drbd-options   --c-fill-target=10240
--c-max-rate=737280   --c-min-rate=20480   --c-plan-ahead=10

That was described as optimal for 10Gbps network on some howtos I found.

Just in case it wasn't applied on the fly, I ran drbdadm adjust on the
resource (both nodes).

Values are stored in /var/lib/linstor.d/linstor_common.conf file.

No speed change in this sync.

If I run 2 similar syncs at the same time, each of them is stuck at 3MB/s.

What did I miss ?

Best regards,
Julien Escario

More information about the drbd-user mailing list