[DRBD-user] DRBD Manual errors

Adam Goryachev adam at websitemanagers.com.au
Thu Apr 21 15:38:23 CEST 2016

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On 21/04/2016 22:53, Lars Ellenberg wrote:
> On Thu, Apr 21, 2016 at 10:01:12PM +1000, Adam Goryachev wrote:
>> Hi,
>> I've found another issue with (my system or) the DRBD docs:
>> http://www.drbd.org/en/doc/users-guide-90/s-check-status
>>> You can get more information by passing the |--verbose| and/or
>>> |--statistics| arguments:
>>> # drbdadm status home --verbose --statistics
>> Except this happens:
>> castle:~# drbdadm status oldNFS --verbose --statistics
> please use:
> # drbdsetup status oldNFS --verbose --statistics
Thanks that solved it.

Is there some reason that there are so many tools used to manage the 
same thing?
There is drbdmanage, drbdadm and drbdsetup.... Is this something that 
might be improved in future versions?
>> While we are at it, I would appreciate if you can provide any tips
>> on how to determine why the volume is "outdated"
> hard to guess.
> may be normal behaviour, may be a bug.
>> and how I can change it back to a working state?
> usually, a resync triggered by disconnect/reconnect should help.
> if not, maybe an explicit "primary" or even "primary --force".
I rebooted one of the nodes, which didn't make any difference (before I 
sent the above message, I was upgrading to 9.0.2).
So I did a drbdadm primary but that didn't work, so added the --force 
which fixed it.

Thank you for your assistance.


More information about the drbd-user mailing list