[DRBD-user] Life lesson; For the archives

Digimer lists at alteeve.ca
Thu Apr 16 04:42:49 CEST 2015

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

I ran into an odd problem today that turned out to be a network issue. I
couldn't find much when I was googling the error, so here is a post for
the archives.

I was building a drbd 8.3.16 (yes, I know...) and when I tried to
'drbdadm connect r0', both nodes hung and /proc/drbd showed:

 0: cs:WFBitMapS ro:Secondary/Secondary ds:UpToDate/Inconsistent C r---d-

In syslog, I saw:

Apr 16 01:30:32 node1 kernel: block drbd0: [drbd0_worker/3112]
sock_sendmsg time expired, ko = 4294967295

Over and over again on node 1 (the one I ran 'drbdadm --
--overwrite-data-of-peer primary r0' on). There were also kernel hung
process errors.

Turns out, I had set the MTU=9000 on the network interfaces (bonded
pairs) but had neglected to enable jumbo frames on my switches.


Don't do what Digimer Dont does.

Papers and Projects: https://alteeve.ca/w/
What if the cure for cancer is trapped in the mind of a person without
access to education?

More information about the drbd-user mailing list