[DRBD-user] DRBD 8.3.13 Sync getting stalled with RHEL 6

Maurits van de Lande M.vandeLande at VDL-Fittings.com
Tue Oct 22 09:00:19 CEST 2013

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hello Vijay,

I have drbd8.3.16 running from the elrepo repository.
To update your package just add the elrepo using the instructions found at the elrepo main page:


To update the packages:

-          stop drbd on the node to be upgraded

-          run:  yum --disablerepo=\* --enablerepo=elrepo install kmod-drbd83 drbd83-utils

-          start drbd

You do not "have" to upgrade to 8.4.

Best regards,
Maurits van de Lande

Van: drbd-user-bounces at lists.linbit.com [mailto:drbd-user-bounces at lists.linbit.com] Namens vijay patel
Verzonden: maandag 21 oktober 2013 23:13
Aan: drbd-user at lists.linbit.com
Onderwerp: Re: [DRBD-user] DRBD 8.3.13 Sync getting stalled with RHEL 6

Thanks Lars for replying. I don't have problem in upgrading DRBD to 8.4 but I am worried about data. Since two nodes are out of sync will upgrade on secondary (removing 8.3 and installing 8.4) will force sync to finish?  If it doesn't happen how should I approach primary upgrade?
From: catchvjay at hotmail.com<mailto:catchvjay at hotmail.com>
To: drbd-user at lists.linbit.com<mailto:drbd-user at lists.linbit.com>
Subject: DRBD 8.3.13 Sync getting stalled with RHEL 6
Date: Mon, 21 Oct 2013 19:04:04 +0530
Hi Friends,

I have already a DRBD 8.3.13 setup running on RHEL 6 servers. After recent kernel upgrade to 2.6.32-358.18.1.el6.x86_64, DRBD sync got stalled on the server. I have tried to invalidate secondary and start the sync but sync is alway 100% mark.

[root at PdCuLx0503p ~]# cat /proc/drbd
version: 8.3.13 (api:88/proto:86-96)
GIT-hash: 83ca112086600faacab2f157bc5a9324f7bd7f77 build by dag at Build64R6, 2012-09-04 12:06:10
 0: cs:SyncSource ro:Primary/Secondary ds:UpToDate/Inconsistent C r-----
    ns:92498284 nr:0 dw:92499372 dr:170166401 al:114209 bm:70 lo:0 pe:0 ua:0 ap:0 ep:1 wo:b oos:44
        [===================>] sync'ed:100.0% (44/276)K
        finish: 8:25:29 speed: 0 (0) K/sec (stalled)
[root at PdCuLx0503p ~]#

I tried to install same version on non production RHEL6 servers but in that also Initial syncs are getting stalled. Is 8.3.13 supported on kernel 2.6.32-358.18.1 and later?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20131022/af8dbd7d/attachment.htm>

More information about the drbd-user mailing list