[DRBD-user] promoting one of new disks

Dan Barker dbarker at visioncomm.net
Wed May 29 21:49:28 CEST 2013

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Yes, you can assume all zeros on new disks and skip the first sync. You can even do it with dirty disks, as long as the file systems are new, but the first verify will be a deusy.

If you'd said what version of DRBD you were running, I'd give you the link in the manual for the correct command. But there are different manual and command syntaxes for 8.3 vs 8.4. Look in the appropriate doc for clear-bitmap.


From: drbd-user-bounces at lists.linbit.com [mailto:drbd-user-bounces at lists.linbit.com] On Behalf Of andreas graeper
Sent: Wednesday, May 29, 2013 7:19 AM
To: drbd-user at lists.linbit.com
Subject: [DRBD-user] promoting one of new disks

pure drbd, no corosync/pacemaker (first attempt, i started to read about lvm,cluster,... some days ago)
when drbd on top of lv (lvm-logical-volumn) and on both nodes the lv are formatted with
mkfs.ext4, cause of error 40 i had to zero the start of lv.
after 'create-md' and 'up' on both nodes (cs:Connected ro=Sec/Sec ds=Inconsistant/Inconsistant) now i tried
 drbdadm --force primary r0
but i got error 17 and found in www a solution
 drbdadm invalidate r0
now automatically sync starts (cs:SyncTarget ro=Sec/Sec ds=Incons/Uptodate)
the peer is implicit declared uptodate this way ?
i should have invalidated the peer if i want to set local node to be primary ? (in case there are actually data on the node that shall become primary)
but the main question:
can i avoid the sync process, if on new disks there are no data ?

sync is done (cs:Connected ro=Sec/Sec ds=Uptodate/Uptodate)

i read, when brbd with pacemaker, then (i guess the resource-manager forces this) only on
primary i have rw-access, and on secondary i cannot even read the mirrored data.
i found the data (lv) already mounted on primary. i created a small file in /mnt/lva (mountpoint declared in /etc/fstab)

now i want to change roles (manual 6.5 basic manual failover).
`mount` or `df -h` does not show the mounted device.

umount /dev/vg_xxx/lv_aaa   => not mounted
umount /mnt/lva                   => not mounted
umount /dev/mapper/vg_xxx-lv_aaa => not mounted
i simply tried (on current primary) :
 drbdadm secondary r
 cd /mnt/lva
 # change on that small file
 /proc/drbd -> ds:uptodate/uptodate
on secondary :
 drbdadm primary r
 -> ro:Primary/Secondary ds:uptodate/uptodate (roles changed)
on new primary i cannot mount the volumn cause its busy
on old primary i can still see the new file
now i stopped drbd on old primary and tried to mount the lv
but it cannot mounted as ext4 anymore, cause it is damaged by the call of dd ?!
how this is done correct: brbd on top of lv with internal metadata ?
 ? i must not zero the head of the formatted lv
 ? i have to force writing metadata to the end of that lv

thanks in advance

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20130529/9b17a89b/attachment.htm>

More information about the drbd-user mailing list