[DRBD-user] Dual Primary dead with 8.4.2

Florian Haas florian at hastexo.com
Tue Dec 4 17:38:09 CET 2012

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On Fri, Nov 16, 2012 at 5:01 PM, Henning Ryll <henning at die-rylls.de> wrote:
> Hello,
> I have tried to make a dual primary setup, but can't get it work.
> I'm using two Celisus 550 Workstations with two sata drives on each machine
> building a softraid 0.
> There are dedicated 1GBit network cards for use with drbd directly connected
> with a cross connect calbe.
> Creating a drbd device on top of /dev/md3 (on top of /dev/sda3 /dev/sdb3)
> works without problems. The initial sync reports no problems.
> It is possible to make one machine primary and the other secondary and vice
> versa. Everything works so far.
> But when trying to get both machines primary the system is respondig very slow
> or is not respondig anymore.
> In /var/log/messages I found a message which looks like a timing problem.
> "PingAck did not arrive in time"
> Then I tried drbd version 8.4.1 and all problems are gone.
> Then I tried 8.4.2rc3. Even no problems. Dual primary is working as expected.
> Then 8.4.2 again. Only single primay works.
> Then I reverted to 8.4.2rc3 and everything is fine again.
> So I gess that there is a bug created with 8.4.2 final :(

Since there has been inexplicable silence on the list for something
that would sound like a pretty nasty bug if confirmed, can I follow up
to ask if anyone has responded to this privately, or if you've been
able to work around that bug, or if there's someone else around to
confirm or dismiss this issue?


More information about the drbd-user mailing list