[DRBD-user] resync-rate not applied

Dennis Jacobfeuerborn dennisml at conversis.de
Thu Aug 16 22:54:36 CEST 2012

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On 08/14/2012 03:51 PM, Nik Martin wrote:
> On 08/13/2012 07:43 PM, Dennis Jacobfeuerborn wrote:
>> On 08/03/2012 03:27 AM, Dennis Jacobfeuerborn wrote:
>>> Hi,
>>> I just set up a traditional drbd primary/secondary system between two hosts
>>> that are connected with gigabit ports. The problem is that the resync rate
>>> is only 5M even though in the config file I set it to 40M.
>>> I also tried:
>>> drbdadm disk-options --resync-rate=40M drbd1
>>> which doesn't result in an error but apparently doesn't get applied either.
>>> I also tried 1M but that gets ignored too.
>>> Any idea what might be going on here?
>>> (This is drbd 8.4.1 on a Centos 6.3 system)
> There is also a setting called
>  c-max-rate that if not set, is set to 20M I think.
> Also, the wild jumping around sounds like a network issue.  I have a 10GB
> crossover cable connecting my two DRBD nodes, and have jumbo frames turned
> on, and can get near wire speed (of the disk bus) through it. Are you doing
> sync through a switch?  If so, are your MTUs set consistently?  Do you have
> any type of broadcast storm control in your switches?  I think DRBD will
> trigger storm control in switches too.

I have no problems with other tools and DRBD 8.3 does not show this problem
either so I doubt it's the network.


More information about the drbd-user mailing list