[DRBD-user] resync-rate not applied

Dennis Jacobfeuerborn dennisml at conversis.de
Tue Aug 14 02:43:45 CEST 2012

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On 08/03/2012 03:27 AM, Dennis Jacobfeuerborn wrote:
> Hi,
> I just set up a traditional drbd primary/secondary system between two hosts
> that are connected with gigabit ports. The problem is that the resync rate
> is only 5M even though in the config file I set it to 40M.
> I also tried:
> drbdadm disk-options --resync-rate=40M drbd1
> which doesn't result in an error but apparently doesn't get applied either.
> I also tried 1M but that gets ignored too.
> Any idea what might be going on here?
> (This is drbd 8.4.1 on a Centos 6.3 system)

Does nobody have any idea?
I just had to re-sync and the "want" value jumped around wildly between 0
K/sec and 80.000 K/sec and the speed it self is terrible:

	finish: 0:05:07 speed: 608 (628) want: 7,160 K/sec
	finish: 0:04:33 speed: 684 (628) want: 43,760 K/sec
	finish: 0:04:38 speed: 680 (628) want: 9,600 K/sec
	finish: 0:05:04 speed: 624 (628) want: 0 K/sec
	finish: 0:04:51 speed: 648 (628) want: 10,760 K/sec

It looks like the variable sync mechanism does more harm than good and I
don't seem to be able to turn it off properly.


More information about the drbd-user mailing list