[DRBD-user] not able to install HAE or DRBD on SLES11sp1

sweatpotatohead scottxiao at gmail.com
Wed Jun 1 05:30:29 CEST 2011

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

(Not sure if the previous post failed or not as I submitted before approval)
dear friends, I am new here, need some advice 

I am trying to setup HA for mySQL on SLES11sp1 

with DRBD and heartbeat. I found the HAE of SLES 

seems has DRBD and SLES10 also have a older 

version. But after I installed   SLES11 and also 

one SLES11sp1,both don't have DRBD. I downloaded 

a DRBD RPM for opensuse,it gave me glic error 

"need glic.so.64 bit",etc. When I tried to 

install those GLBIC stuff ,also errors for 

dependencies again. I tried to use the source 

code build but system has no git and stuck there 

too. I got HAE ISO and match to my DVD drive of 

the VM, but the pattern doesn't show HAE. it only 

allow me to install the drbd tool into Yast but 

from Yast I am not able configure any DRBD 

because the error is the drbd still not found. 

where I should start  please? wondering if I 

should do a full install for everything as I 

selected express install for the OS. Then it may 

include all the prerequisite ? But HA extention 

still not sure how to install. Any advice 

please?Thanks! SP

my sles11sp1 is running on vm of vmware workstation 6.5 , 64 bit SLES. 
linux-iplx:~/bin/temp # ls 
linux-iplx:~/bin/temp # rpm -i drbd-8.3.10-25.1.x86_64\(sles11sp1.rpm 
warning: drbd-8.3.10-25.1.x86_64(sles11sp1.rpm: Header V3 DSA signature:
NOKEY, key ID 7b709911 
error: Failed dependencies: 
        libc.so.6()(64bit) is needed by drbd-8.3.10-25.1.x86_64 
        libc.so.6(GLIBC_2.11)(64bit) is needed by drbd-8.3.10-25.1.x86_64 
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by drbd-8.3.10-25.1.x86_64 
        libc.so.6(GLIBC_2.3)(64bit) is needed by drbd-8.3.10-25.1.x86_64 
        libc.so.6(GLIBC_2.3.4)(64bit) is needed by drbd-8.3.10-25.1.x86_64 
        libc.so.6(GLIBC_2.4)(64bit) is needed by drbd-8.3.10-25.1.x86_64 
        libc.so.6(GLIBC_2.7)(64bit) is needed by drbd-8.3.10-25.1.x86_64 
        libc.so.6(GLIBC_2.8)(64bit) is needed by drbd-8.3.10-25.1.x86_64 
linux-iplx:~/bin/temp # 

linux-iplx:/usr/src/packages # ls 
BUILD                  drbd-8.3.10.tar.gz        RPMS     SPECS 
drbd-8.3.10(2).tar.gz  git-0.99.9k-1.x86_64.rpm  SOURCES  SRPMS 
linux-iplx:/usr/src/packages # rpm -i git-0.99.9k-1.x86_64.rpm 
error: Failed dependencies: 
        git-core is needed by git-0.99.9k-1.x86_64 
        git-svn is needed by git-0.99.9k-1.x86_64 
        git-cvs is needed by git-0.99.9k-1.x86_64 
        git-arch is needed by git-0.99.9k-1.x86_64 
        git-email is needed by git-0.99.9k-1.x86_64 
        gitk is needed by git-0.99.9k-1.x86_64 
linux-iplx:/usr/src/packages # rpm -i
error: Failed dependencies: 
        git = is needed by git-all- 
        git-svn = is needed by git-all- 
        git-cvs = is needed by git-all- 
        git-arch = is needed by git-all- 
        git-email = is needed by
        gitk = is needed by git-all- 
        gitweb = is needed by git-all- 
        git-gui = is needed by git-all- 
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by
linux-iplx:/usr/src/packages # 

View this message in context: http://old.nabble.com/not-able-to-install-HAE-or-DRBD-on-SLES11sp1-tp31746331p31746331.html
Sent from the DRBD - User mailing list archive at Nabble.com.

More information about the drbd-user mailing list