[DRBD-user] DRBD trace with RHEL6.1 upgrade

Florian Haas florian.haas at linbit.com
Wed Aug 3 11:22:53 CEST 2011

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On 2011-08-02 20:34, David Coulson wrote:
> I have a pair of systems running RHEL6 w/ DRBD, cman/pacemaker and
> clvmd. They worked happily for about 6 months on RHEL6.0. I applied
> updates to the systems today taking them to RHEL6.1 (as of about a week
> ago). They are running the release of DRBD, both before and
> after the RHEL kernel update. Both boxes have kernel paniced since the
> update (specifically when I tried to resolve a split-brain issue in
> drbd), so I'm working on tracking down the specific issues - This seemed
> like a good place to start. My DRBD resource is attached to an LV on the
> local disk of each box.
> When they boot I get the following trace:
> block drbd0: Starting worker thread (from cqueue [1928])
> block drbd0: disk( Diskless -> Attaching )
> block drbd0: Found 4 transactions (8 active extents) in activity log.
> block drbd0: Method to ensure write ordering: barrier
> block drbd0: Backing device's merge_bvec_fn() = ffffffffa0002af0
> block drbd0: max_segment_size ( = BIO size ) = 32768
> block drbd0: drbd_bm_resize called with capacity == 41941688
> block drbd0: resync bitmap: bits=5242711 words=81918
> block drbd0: size = 20 GB (20970844 KB)
> block drbd0: recounting of set bits took additional 0 jiffies
> block drbd0: 136 MB (34816 bits) marked out-of-sync by on disk bit-map.
> block drbd0: disk( Attaching -> UpToDate )
> ------------[ cut here ]------------
> WARNING: at block/blk-core.c:1222 __make_request+0x477/0x500() (Not
> tainted)
> Hardware name: System x3550 M2 -[7946AC1]-
> block: BARRIER is deprecated, use FLUSH/FUA instead

This is a result of the RHEL 6.1 kernel containing backports of
post-2.6.32 upstream code that removed the notion of barriers from the
I/O stack. Strictly speaking, this does not break the kernel ABI so this
is no violation of Red Hat's own policy, but it's causing some headaches

The issue you are facing is fixed in DRBD 8.3.11 and DRBD 8.4.0. LINBIT
support customers were provided with a version that fixes this issue,
promptly after it became known.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20110803/7a3f7330/attachment.pgp>

More information about the drbd-user mailing list