[DRBD-user] drbdadm cstate/dstate/role warning about unknown tags: unknown tag = (integer) 0 [len: 0]

Steven Bakker steven.bakker at ams-ix.net
Tue Feb 16 16:17:31 CET 2010

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.


I've just had my primary Openfiler node crap out on me, and managed to
fail over to my secondary node.

The setup is:

- Two nodes: dix1, dix2
- DRBD primary/secondary
- Bunch of partitions set up as DRBD devices
- LVM volumes over the DRBD devices.

- drbdadm reports itself (on both nodes) as:
        Version: 8.3.2 (api:88)
        GIT-hash: dd7985327f146f33b86d4bff5ca8c94234ce840e build by
        phil at fat-tyre, 2009-07-03 15:35:39
Dix1 was primary and got in a stuck state, doing something on LVM (bad
snapshot situation, tried an lvremove).

I rebooted "dix1", causing "dix2" to take over. The reboot of dix1 took
some time, because the relevant DRBD volumes were still in use (by the
unkillable "lvremove" presumably).

On rebooting dix1, I received warnings about split-brain on dix2,
related to two of the DRBD devices.

So, figuring that dix1 was the broken side anyway, I typed:

        dix1# drbdadm invalidate pv00_drbd
        dix1# drbdadm invalidate pv01_drbd

And on both nodes:

        dix1# drbdadm connect pv00_drbd
        dix2# drbdadm connect pv00_drbd
        dix1# drbdadm connect pv01_drbd
        dix2# drbdadm connect pv01_drbd

When I run "drbdadm cstate" on the sync source for those two devices
(dix2), I get:

        dix2# drbdadm cstate pv00_drbd
        # (4152)  unknown tag = (int64) 0 [len: 0]
        # Found unknown tags, you should update your
        # userland tools
        dix2# drbdadm cstate pv01_drbd
        # (1245)  unknown tag = (int64) 0 [len: 0]
        # Found unknown tags, you should update your
        # userland tools

I'm getting the same kind of output on "role" and "dstate" as well. Mind
you, only on the primary node. The secondary doesn't show these

Other than that, it all seems to run fine again.

Still, I'm a little worried about a field that has length 0... Should I
be? Any help will be appreciated.

Best regards,

More information about the drbd-user mailing list