[DRBD-user] /dev/drbd0 incorrect size

Chad Sine chad at unixenthusiast.org
Wed Apr 28 23:52:18 CEST 2010

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

DRBD Users,

I'm setting up 2 CentOS 5.4 x86_64 servers to use DRBD.  I set them up to do
RAID1, but /dev/drbd0 only shows up at 12GB instead of the 1.8 TB that the
underlying devices have.

Both boxes are configured just like this, with 1800GB for /dev/sda4

[root at centos54 etc]# parted
GNU Parted 1.8.1
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print

Model: Dell VIRTUAL DISK (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      32.3kB  206MB   206MB   primary  ext3         boot
 2      206MB   108GB   107GB   primary  ext3
 3      108GB   120GB   12.8GB  primary  ext3
 4      120GB   1920GB  1800GB  primary

Here is the /etc/drbd.conf used on each

global { usage-count no; }
common { syncer { rate 1000M; } }
resource drbd-data {
        protocol C;
        startup {
                wfc-timeout  15;
                degr-wfc-timeout 60;
                become-primary-on centos54;

#       disk {
#               size 1700G;
#       }
        net {
                cram-hmac-alg sha1;
                shared-secret "myP4$$";
        on centos54 {
                device /dev/drbd0;
                disk /dev/sda3;
                meta-disk internal;
        on centos54_2 {
                device /dev/drbd0;
                disk /dev/sda3;
                meta-disk internal;

>From there, I ran the following command to create the md on each box

# drbdadm create-md drbd-data

Then I ran the following command on the primary system

# drbdadm -- --overwrite-data-of-peer primary drbd-data

Everything looks to synchronize with UpToDate for each device and centos54
is primary.

However, now if I run parted on /dev/drbd0, it is only 12 GB, instead of
1.8TB.  I tried doing the following, but I still only get a 12GB partition

# mkfs.ext3 /dev/drbd0
# mount /dev/drbd0 /media

What can I do to get the full 1.8 TB of mirrored storage?  Unfortunately, I
don't have the output of the last few commands available, sine the server is
in use at the moment.  I'll be able to test and give proper output this
weekend, when I swap out hard drives and attempt this transition again.

Thank You,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20100428/d865cafe/attachment.htm>

More information about the drbd-user mailing list