[DRBD-user] Migrate from 0.7.11 to 8.3.1

Jérôme Loyet jerome at loyet.net
Thu Oct 29 12:26:11 CET 2009

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

hi folks,

I tried to migrate a 0.7.11 DRDB cluster to a 8.3.1 but it fails.

I follow the procedure described in Florian's blog (

But when I tried to migrate the metadata, I got some errors.

I have have 2 resources to migrate: vol0 and vol1. Each resource is
configure exactly the same way (on local disk, metadata are in the first
partition and the data on the second partition). Each resource has one
dedicated physical drive.

Errors returned for each resource is different:

[root at op0men07s ~]# drbdadm create-md vol0
md_offset 0
al_offset 4096
bm_offset 36864

Found ext3 filesystem
This would corrupt existing data.
If you want me to do this, you need to zero out the first part
of the device (destroy the content).
You should be very sure that you mean it.
Operation refused.

Command 'drbdmeta 0 v08 /dev/cciss/c0d1p1 0 create-md' terminated with exit
code 40
drbdadm create-md vol0: exited with code 40

[root at op0men07s ~]# drbdadm create-md vol1
md_offset 0
al_offset 4096
bm_offset 36864

Found some data
 ==> This might destroy existing data! <==

Do you want to proceed?
[need to type 'yes' to confirm] ^C

Do you have any clue on what's going on and what to do to make it works.

Thx a lot.

++ Jerome
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20091029/e41b257b/attachment.htm>

More information about the drbd-user mailing list