[DRBD-user] Centos5 DRBD 8.3 protocol C very slow

Coert Waagmeester lgroups at waagmeester.co.za
Tue Jul 28 11:20:43 CEST 2009

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hello all DRBDers,

Great product!

My DRBD setup is as follows:

2 hosts with each:
2x 1TB seagate SATA software RAID1
LVM on top of that
crossover gigabit link between the two.

My drbd.conf:
global {
  usage-count yes;
common {
  protocol C;
  syncer { rate 50M; }
  net {
  startup { wfc-timeout 0 ; }
#####<I skip 6 drbd sections, similar setup as drbd7>
resource testlv {
  device    /dev/drbd7;
  disk      /dev/vg0/testlv;
  meta-disk internal;

  on baldur.mydomain.local {
  on thor.mydomain.local {

the problem I am experiencing is that the maximum transfer rate is too

I get full through-put on the back-to-back gigabit ( 990Mb/sec )

as in the config file drbd7 mirrors a logical volume mounted on dom0
when i run dd on that lv:
# dd if=/dev/zero of=300meg.file bs=1M count=300 oflag=direct
300+0 records in
300+0 records out
314572800 bytes (315 MB) copied, 39.5295 seconds, 8.0 MB/s

I have tried no-disk-flush and no-md-flush.

When I use protocol A the maximum throughput is also only 8MB/sec,
but as soon as I run 'drbdadm disconnect all' on the secondary host, and
rerun the dd I get 32MB/sec!

Any tips would be greatly appreciated!

Kind regards,

PS I sent a mail prior to this with an attachment, but that is moderated

More information about the drbd-user mailing list