[DRBD-user] bind before connect failed, err = -99

Richard Hector richard at catalyst.net.nz
Mon Jul 13 07:22:17 CEST 2009

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi all,

One of my 2 machines doesn't seem to connect at boot time - doesn't
matter whether it's configured to come up as primary or secondary. This,
at a guess, seems relevant:

[   29.196417] drbd0: conn( Unconnected -> WFConnection ) 
[   29.196417] drbd0: bind before connect failed, err = -99
[   29.196417] drbd0: conn( WFConnection -> Disconnecting ) 

I've tried to find any docs regarding this without success - that bind
is an internal kernel one, not bind(2) (the syscall), right? My
expertise at navigating the kernel source is rather limited ...

If I run /etc/init.d/drbd restart after boot, it comes up fine.

Both machines are Debian Lenny, amd64, with drbd 8.3 from backports.org.

Any suggestions? Any more useful info I can supply?



-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linbit.com/pipermail/drbd-user/attachments/20090713/afe15cee/attachment.pgp>

More information about the drbd-user mailing list