[DRBD-user] Oops kernel

gilberto nunes gilberto.nunes at selbetti.com.br
Thu Dec 3 20:11:09 CET 2009

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Hi all

I compile a kernel with xen and kemari...
Now, I try put to work together drbd 8.3.6 and I have some problem...
When I compile drbd, everything goes ok.
I run configure with this flags:

--with-km --with-initdir=/etc/init.d

And define KDIR variable to directory where I compile the Xen kernel.

All commands run without error.
But when I attempt start drbd (service drbd start), I get Oops kernel error:
Unable to handle kernel paging request at ffff8f003369e480 RIP:
 [<ffffffff803f8c65>] sha_transform+0x16/0x1f1
Oops: 0000 [2] SMP
Modules linked in: sha1 ocfs2_dlmfs ocfs2_dlm ocfs2_nodemanager configfs 
bridge drbd ipv6 binfmt_misc dm_mirror dm_multipath dm_mod video thermal 
sbs processor i2c_ec i2c_core fan container button battery asus_acpi ac 
parport_pc lp parport sr_mod cdrom sg tg3 pcspkr usbkbd usbhid serio_raw 
ide_disk ata_piix libata sd_mod scsi_mod ext3 jbd uhci_hcd ohci_hcd 
ehci_hcd usbcore
Pid: 2937, comm: drbd0_receiver Tainted: GF #1
RIP: e030:[<ffffffff803f8c65>]  [<ffffffff803f8c65>] 
RSP: e02b:ffff880033563b78  EFLAGS: 00010286
RAX: 0000000000000040 RBX: ffff8f003369e480 RCX: 0000000000000000
RDX: 0000000000000000 RSI: ffff8f003369e480 RDI: ffff880033563be0
RBP: ffff8f003369e480 R08: 0000000094ba3684 R09: 0000000000000000
R10: ffff880033563b90 R11: ffffffff802d7858 R12: 0000000000000040
R13: ffff880036de9e18 R14: ffff880033563be0 R15: ffff880036de9e10
FS:  00002ae688281230(0000) GS:ffffffff804e0080(0000) knlGS:0000000000000000
CS:  e033 DS: 0000 ES: 0000
Process drbd0_receiver (pid: 2937, threadinfo ffff880033562000, task 
Stack:  ffffffff882ac092 ffff880033563d70 ffffffffffffffff 0000000000000000
 ffff8f003369e480 ffff8f003369e480 0000000000000040 0000000000000040
 ffff880033563be0 ffff880036de9e10 ffffffff882ac072 0000000000000000
Call Trace:
 [<ffffffff882ac092>] :sha1:sha1_update+0x92/0xb9
 [<ffffffff882ac072>] :sha1:sha1_update+0x72/0xb9
 [<ffffffff802d7922>] update+0xca/0x112
 [<ffffffff802d7922>] update+0xca/0x112
 [<ffffffff802d7f38>] crypto_hmac+0x33/0x4f
 [<ffffffff881fd2fe>] :drbd:drbd_do_auth+0x27f/0x49d
 [<ffffffff881fdfe3>] :drbd:drbd_connect+0x4d1/0x5d4
 [<ffffffff8820048d>] :drbd:drbdd_init+0x45/0x104
 [<ffffffff8820fcf9>] :drbd:drbd_thread_setup+0x127/0x1e1
 [<ffffffff80209f78>] child_rip+0xa/0x12
 [<ffffffff8021472b>] xen_send_IPI_mask+0x0/0xf5
 [<ffffffff8820fbd2>] :drbd:drbd_thread_setup+0x0/0x1e1
 [<ffffffff80209f6e>] child_rip+0x0/0x12

Code: 8b 04 96 0f c8 89 04 97 48 ff c2 48 83 fa 10 75 ef 30 d2 8b
RIP  [<ffffffff803f8c65>] sha_transform+0x16/0x1f1
 RSP <ffff880033563b78>
CR2: ffff8f003369e480

I do not know what to do here!

Somebody anytime get the same error????


*Gilberto Nunes Ferreira*
*Selbetti Gestão de Documentos*
*Telefone: +55 (47) 3441-6004*
*Celular: +55 (47) 8861-6672*

/"Bendita a nação cujo Deus é o SENHOR!"/
*99* <><

More information about the drbd-user mailing list