[DRBD-user] Downgrading?

Lars Ellenberg lars.ellenberg at linbit.com
Mon May 26 11:02:01 CEST 2008

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

On Mon, May 26, 2008 at 10:06:26AM +0200, Stefan Löfgren wrote:
> Hi list!
> I've been monitoring the thread about the stable/unstable versions and so on
> and do not wish to add to this discussion.
> But, I have problems that might be related to this issue...
> Background:
> I've been testing with kernel and DRBD 0.7.25 in virtual machines and
> this is working just fine so far.
> Now, in production I had to change to kernel (due to hardware
> compability-issues) and DRBD 8.2.5...
> This setup turned out to be rather useless due to bugs in 8.2.5 (the ones
> fixed in 8.0.12). So, went for 8.2.6rc1 and I was able to get the resource
> running for more than 15 minutes.
> Everything looked good. But now, 10 days later, I have a feeling that I was
> mistaken. I'm having troubles with kernel-panics. I'm not able to find the
> source of the problem, but can at least say that one of the crashes was
> related to some failed kalloc-calls (and I think it was in DRBD, i've seen
> this more than once)...
> I'm not sure where to begin my search for errors. The system refuses
> SHH-connections (all networkconnection for that matter). The secondary node is
> working fine, but not the primary. This could in theory be connected with
> other softwares running on the primary. These are:
> Samba, svnserve, X and VMWare Workstation.
> (well, the system does not panic right away but refuses connections and the
> HDD-LEDs it lit all the time. And when I try to unmount and go into secondary
> it crashes).
> Yes, I know there's a red flag on vmware that uses kernel-modules. But the
> other softwares are strictly in user-space and should not, in theory, cause
> this kind of problems, right?
> I tried to downgrade to kernel 2.4.x but the hardware was simply not
> supported... :(
> This is not a discussion whether to call 8.2.5 stable or not, it just didn't
> work.... ;) And I really need to fix it or change platform (a good old rsync
> once a day is better than crashes one a week)... I really love the idea with
> DRBD and I would really love to get it running...
> Any suggestions on what I should do?

setup serial console.
if you can, run a mlocked high priority (ulimited) busybox getty on it,
that should let you in even if you don't get in any other way,
so you can diagnose the rest.

_capture_ one of those panic messages/oopses whatever,
and let us have a look ourselves.
"hey, it does not work, it may be anyones fault or none at all"
is not a very useful bug report :-]

which hardware exactly is it that forces you to use the latest kernel,
to get the latest drivers?
what is that latest driver for -- the network card?
and now you experience network related problems?
tried an other nic already?

how much RAM?

how much storage?
how much of that for DRBD?

32bit or 64bit kernel?

> Downgrade to DRBD 8.0.12? Will this make it better?

don't think so

> Known issues?


> Known issues together with VMWare?
> Will rc2 make a difference?

don't think so

> Anyone else been running 2.6.24.x and DRBD 8.2.x with success


> (DELL PowerEdge R200)? Maybe even kernel problems?


: Lars Ellenberg                           http://www.linbit.com :
: DRBD/HA support and consulting             sales at linbit.com :
: LINBIT Information Technologies GmbH      Tel +43-1-8178292-0  :
: Vivenotgasse 48, A-1120 Vienna/Europe     Fax +43-1-8178292-82 :
please don't Cc me, but send to list -- I'm subscribed

More information about the drbd-user mailing list