[DRBD-user] Re: kernel oops on secondary after online verify in DRBD 8.2.4

Jeffrey Goris jeff.goris at whiterabbit.com.au
Thu Feb 21 04:46:15 CET 2008

Note: "permalinks" may not be as permanent as we would like,
direct links of old sources may well be a few messages off.

Ben Clewett <ben at ...> writes:
> Hi,
> I had a similar problem yesterday on 8.2.4.  Created a new resource on 
> my SUSE 10.3, which connected no problem.  The inital sync did not cut 
> in, so it was forced using 'drdbadm invalidate'.  (Is this normal, feels 
> like a bug to me?)  This completed, but left the box in a state where no 
> new processes could be created.  Nothing in /var/log/messages.

In addition to the kernel oops after a verify, I have also been having some
issues where I was unable to start new processes on one of the nodes (the
secondary from memory).

> So I had to disconnect power.  It worked second time.
> I tried to replicate this morning in order to see any more messages, but 
> now have another problem.  DRBD jumped into state 'stalled' from where 
> it will not budge, shown below.  However I can reboot this time, and it 
> is now completing.
> I didn't see these problems with my previous installs (8.2.1) which I've 
> run for months on several servers without DRBD issue.  This suggests to 
> me that there may be problems with this version.
> Regards, Ben.

I just upgraded to DRBD 8.2.5 and performed an online verify which worked fine
and did not result in a kernel oops. Did 8.2.5 fix this, or was it the fact that
there've been a couple of kernel updates in Fedora 8 lately? I'm not sure, but I
am glad that it is working now.


More information about the drbd-user mailing list